Mangoh Yellow No Longer Connects to Octave

We have our first mangoh yellow successfully connected it to Octave and updated the firmware. We have built an image from the mangoh github repo and installed it. We have built the helloworld samples from the tutorials and installed those. Sometime in the process, however, we lost the connection to Octave such that it no longer connects. I have tried reverting back to mangOH-yellow-wp77xx_0.7.0-octave.spk and that doesn’t fix it. When I run ‘legato version’ I get:


but it is strange that my helloWorld app is still there. I must not completely understand where apps live compared the spk image that I’ve been installing.

When I run ifconfig, the rmnet0 is not claiming an ip address:
rmnet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:2000 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

The output of ‘cm radio’ seems ok:

root@swi-mdm9x28-wp:~# cm radio status
Power: ON
Current Network Operator: Sierra Wireless
Current RAT: LTE network (LE_MRC_RAT_LTE)
Status: Registered to a roaming network (LE_MRC_REG_ROAMING)
Signal: Very strong signal strength (5)
PS: Packet Switched Registered, home network (LE_MRC_REG_HOME)

Here is more:
root@swi-mdm9x28-wp:~# cm data
Index: 1
APN: iot.swir
PDP Type: IPV4V6
Connected: no

Tried running ‘cm data connect’ and this is what I get:
root@swi-mdm9x28-wp:~# cm data connect
Setting up profile 1
Connecting … ok
Checking if device ‘rmnet_data0’ is up … ok
Routing inet … ok
Updating /etc/resolv.conf … ok
Testing connection … failed

How do I get my mangoh yellow back to auto connecting?