mangOH Yellow LTE doesn't work?

Hi there,

I’ve been experimenting with the mangOH Yellow over the past several weeks, and I simply can’t get it to connect on LTE. It always connects to T-Mobile’s 2G network. I’ve tried everything. I’m using the 3-month Octave trial, and I’ve also tried a Hologram SIM card.

Various relevant info:

Firmware Version:              SWI9X06Y_02.32.02.00 c2e98c jenkins 2019/08/30 07:28:21
Bootloader Version:            SWI9X06Y_02.32.02.00 c2e98c jenkins 2019/08/30 07:28:21
MCU Version:                   002.013
PRI Part Number (PN):          9909138
PRI Revision:                  001.001 
Carrier PRI Name:              SIERRA
Carrier PRI Revision:          001.027_000

If I prevent GSM fallback by doing:

cm radio rat LTE

…then it just never registers on the network. I end up seeing stuff like this:

root@swi-mdm9x28-wp:~# cm radio
Power:                         ON
Current Network Operator:      AT&T
Current RAT:                   Module not registered on network, RAT not available
Status:                        Registration was denied, usually because of invalid access credentials (LE_MRC_REG_DENIED)
Signal:                        Strong signal strength (4)
PS:                            Packet Switched Not registered (LE_MRC_REG_NONE)

(It also sometimes shows Verizon instead of AT&T)

As soon as I allow GSM fallback:

cm radio rat GSM LTE

Then it eventually connects to T-Mobile:

root@swi-mdm9x28-wp:~# cm radio
Power:                         ON
Current Network Operator:      T-Mobile
Current RAT:                   GSM network (LE_MRC_RAT_GSM)
Status:                        Registered to a roaming network (LE_MRC_REG_ROAMING)
Signal:                        Strong signal strength (4)
PS:                            Packet Switched Not registered (LE_MRC_REG_NONE)

I’m in a pretty rural area, so I suppose that poor coverage is a possibility, but I read that AT&T has nationwide LTE-M coverage. AT&T definitely has LTE coverage here, so wouldn’t that mean that LTE-M should work too? I can’t get the Hologram card to work with AT&T or Verizon’s LTE networks either, and I believe it is supposed to be compatible with both carriers. Same thing – LE_MRC_REG_DENIED. I tried the AT&T firmware as well…didn’t seem to matter.

Here’s the output of AT+COPS=?:

+COPS: (1,"T-Mobile","T-Mobile","310260",0),(1,"AT&T","AT&T","310410",7),(1,"313 100","313 100","313100",7),(1,"Verizon","Verizon","311480",7),,(0,1,2,3,4),(0,1,2)

Am I going crazy? Am I missing something simple?

Thanks for any advice!

Do you know what LTE bands you get in your area?
Can you try the external LTE antenna that we provide in the kit?

I don’t know for sure which LTE bands are available. cellmapper.net says AT&T uses bands 2, 12, and 17 in my area.

I tried the taoglas FXUB63 antenna (connected to “MAIN” connector, changed SW403.5 to ON) but it doesn’t seem to make a difference at all. Still only connects to T-Mobile 2G. AT+COPS started showing US Cellular as another available network, but other than that, no change.

Try the following command
at!selciot=2

It looks like it was already set that way to begin with:

AT!SELCIOT?
Current Operating Mode: 0x2

Supported Operating Modes:
LTE WB:  0x01
LTE M1:  0x02
LTE NB1: 0x04

OK
AT!SELCIOT=2                                                                    
OK                                                                              
AT!SELCIOT?                                                                     
Current Operating Mode: 0x2                                                     
                                                                                
Supported Operating Modes:                                                      
LTE WB:  0x01                                                                   
LTE M1:  0x02                                                                   
LTE NB1: 0x04                                                                   
                                                                                
OK

@dlahay can you look at this?

@dougbrown,

Given the response to the at+cops=? command, this part, (1,“AT&T”,“AT&T”,“310410”,7), shows that you can see the AT&T M1 network (the 7 indicates LTE and in the WP7702’s case this can only mean M1).

What might be interesting is ending the below commands.
at+cmee=1 //Set error reporting on
at+cops=1,2,“310410”,7 //Manually force the unit to attach to AT&T LTE which should result in a response to work with.
at+cops=0 //Set the unit back to automatic

This is normally a problem with roaming rights.

Regards

Matt

Hi @mlw,

Thank you for the info and idea! That’s something that I’ve been wondering – if a cell tower has LTE support, but it doesn’t have Cat-M1 support, would it show up in AT+COPS=? – sounds like you’re implying it won’t. That’s helpful to know.

I just ran the command to force AT&T as a test (using the built-in Sierra SIM that I’m using with the Octave trial). Here’s what I got:

AT+CMEE=1
OK
AT+COPS=1,2,"310410",7
+CME ERROR: 30

+CREG: 3

+CGREG: 3

+CEREG: 3

It looks like CME ERROR 30 means “No network service”. Any thoughts on what this might possibly mean?

Thanks,
Doug

@dougbrown,

Since the unit is a 2G/NB1/M1 only unit, yes it will only see an M1 bearer, which is indicated as 7, rather than cat 0+, which also indicated as 7, 9 is NB1 and 0 is 2G.

Normally 30 is exactly what it says, in this case it must be a reject from the network, probably an unsubscribed service hence it is falling back to 2G on Tmo.

Regards

Matt

@mlw thanks for the info.

I guess I’m confused now – this is happening with the built-in Sierra SIM that I activated with the Octave trial. Does this mean it’s not provisioned properly for LTE-M? Who can I contact about this?

Hi Doug,

We have released a non-octave sku firmware. Could you use that firmware to see if a different sim works in your area?

regards,
Ashish

Hi Ashish,

Thanks for the suggestion. First I tried the 0.4.0 Octave firmware with the internal SIM, and saw the CME ERROR 30 again. Then, I tried the non-Octave 0.4.0 firmware with a SIM card from Hologram, and successfully connected over LTE (although the connection defaulted to T-Mobile 2G until I forced it to AT&T’s network with the AT+COPS command above).

So…it looks like the module’s internal SIM (activated with Octave trial) doesn’t have permission to connect on LTE for some reason. The external SIM does work okay on LTE.

@asyal @mlw Thank you both for all of your help on this. I think this means I’m good to go, at least with Hologram…

I just wanted to add a few more details. Version 0.3.0 does not work with LTE on the Hologram card – I also get CME ERROR 30. (I built it without Octave by checking out the mangOH project in my leaf workspace and doing OCTAVE=0 make yellow_spk in order to test). Installing 0.3.0 breaks it, installing 0.4.0 (either the spk on the website or my own) fixes it. So something about 0.4.0 was responsible for fixing the LTE issue.

0.3.0 sets a private apn so you couldnt get out to a different network.
With 0.4.0 with non-octave, you are not set to private apn so it works.

But I built 0.3.0 without Octave, so it wasn’t forcing the iot.swir APN, and the problem was still there…is it something at a different level internally? And does the APN setting prevent from even attaching to the network?

Will need to look into it.
Let me know if this correct for 0.4.0 (in your geographical area)
a. non-Octave: connects to LTE using Hologram
b. Octave: doesnt connect to LTE

What you said is correct with 0.4.0. And with 0.3.0 I never got LTE to work with or without Octave.

I’m not sure if this is the right place to report it, but I’ve also noticed a couple of other anomalies with 0.4.0. The module has powered itself off a few times, almost like it’s going into ULPM on its own or something. The console output I see is:

swimcu_pm_wusrc_config: check statep->gpio_pin_mask 0x0
pm_set_mcu_ulpm_enable: wakeup source setup mask=0x2
rcK: Executing run_K_scripts...
...etc

I don’t have any apps trying to do this. Also, pmtool shutdown no longer works. It prints out “Initiated shutdown of MDM” but nothing happens after that, until I do “AT+CPSMS=0” as suggested in another thread. Changing back to 0.3.0 allows pmtool shutdown to work normally again as expected.

Edit: The pmtool shutdown problem seems to be my own fault, because your supplied 0.4.0 spk doesn’t exhibit the same symptom. Not sure why I can’t build a working spk.

Could you please open a separate thread for that ? thanks.