mangOH red unable to connect "Registration was denied"


#1

My issue seems similar to this:

I have a new mangOH red with a WP8548 in it and I’m using the Legato VM. I’ve followed the “getting started guide”, registered the SIM with my airvantage account, did the “cm radio off”, “cm data pdp ipv4”, “cm radio on” commands, and “cm radio” gives me this:

root@swi-mdm9x15:~# cm radio
Power:                 ON
Current Network Operato T-Mobile
Current RAT:           UMTS network (LE_MRC_RAT_UMTS)
Status:                Registration was denied, usually because of invalid access credentials (LE_MRC_REG_DENIED)
Signal:                Good signal strength (3)
PS:                    Packet Switched Not registered (LE_MRC_REG_NONE)

root@swi-mdm9x15:~# cm radio
Power:                 ON
Current Network Operato T-Mobile
Current RAT:           UMTS network (LE_MRC_RAT_UMTS)
Status:                Registration was denied, usually because of invalid access credentials (LE_MRC_REG_DENIED)
Signal:                Good signal strength (3)
PS:                    Packet Switched Not registered (LE_MRC_REG_NONE)

root@swi-mdm9x15:~# cm radio
Power:                 ON
Current Network Operato 
Current RAT:           Not available
Status:                Not registered and not currently searching for new operator (LE_MRC_REG_NONE)
Signal:                No signal strength (0)
PS:                    Packet Switched Unknown state (LE_MRC_REG_UNKNOWN)

Yesterday, it randomly connected to AT&T for a bit and I was able to ping out to Google’s DNS server (8.8.8.8), but the “redSensorToCloud” app was never able to communicate with airvantage, and my “connection” only lasted for a little while. Most of the time, I just get the “Registration was denied, usually because of invalid access credentials (LE_MRC_REG_DENIED)” message. More info below:

root@swi-mdm9x15:~# cm info
Device:                WP8548
IMEI:                  3593770XXXXXXXX
IMEISV:                2E
FSN:                   LL8054XXXXXXXX
Firmware Version:      SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
Bootloader Version:    SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
MCU Version:           002.004
PRI Part Number (PN):  9907396
PRI Revision:          01.00
Carrier PRI Name:      GENERIC
Carrier PRI Revision:  001.034_000
SKU:                   1103552
Last Reset Cause:      Unknown
Resets Count:          Expected: 0	Unexpected: 0

root@swi-mdm9x15:~# cm sim info
Type:                  EXTERNAL_SLOT_1
ICCID:                 893324010000XXXXXXXX
Home Network Operator: Proximus
EID:                   
IMSI:                  2060188XXXXXXXX
Phone Number:      

Thanks for any help.


#2

Adding “cm data”:

root@swi-mdm9x15:~# cm data
Index:                 1
APN:                   internet.sierrawireless.com
PDP Type:              IPV4
Connected:             no

#3

Your cm radio status shows that your registration was denied.
If you are using the sierra wireless SIM, you need to activate it by registering to the airVantage following the Getting Started Guide.
Then you may need to power cycle the device and check cm radio. You have to successfully register to the network (see example below) to be able to push your data to the airVantage by running the redSensorToCloud app.
root@swi-mdm9x15:~# cm radio
Power: ON
Current Network Operator: Rogers Wireless
RAT: GSM network (LE_MRC_RAT_GSM)
Status: Registered to a roaming network (LE_MRC_REG_ROAMING)
Signal: Very strong signal strength (5)
PS: Packet Switched Registered, home network (LE_MRC_REG_HO ME)


#4

Did you try “cm data connect” command? I think mine was using ATT and I had to use that command. I ended up just putting my personal ATT sim card in and using it for a bit. If you want to use air vantage, then yes you will have to set it up. But it should still be able to connect to the network and register without it.


#5

Thanks for the reply and information.

I am using the Sierra Wireless SIM that came with the mangOH Red development kit. I’ve power cycled and done all the cm radio commands (cm radio off, cm data pdp ipv4, cm radio on, cm radio) many times at this point – still no luck, unfortunately.


#6

I have tried the cm data connect command. That doesn’t seem to work for me either, at this point. My whole goal is to get the Airvantage piece working, so I guess I’ll continue troubleshooting.

root@swi-mdm9x15:~# cm data connect
Setting up profile 1
Setting access point name ... ok
Setting packet data protocol ... ok
Setting Authentication ... ok
Connecting ... failed
Sun Jan  6 20:55:52 UTC 1980 - Connection Failure: LE_FAULT

#7

I have the exact same setup. WP 8548 on a mangOH Red. I was able to get it working with the Sierra sim and my own ATT SIM card from my phone. I never did anything with the IPV4. Whatever it used was default. Let me swap out my HL for the WP and I will see if I can get it working again and post the steps. If you have a SIM card you use in your phone, you could get that too.


#8

Ok. I just brought mine up. I popped in my Sierra SIM card with my WP8548 and changed the APN to internet.sierrawireless.com. When I typed in data connect, it worked.

root@swi-mdm9x15:~# cm data
Index: 1
APN: phone
PDP Type: IPV4V6
Connected: no
root@swi-mdm9x15:~# cm data apn internet.sierrawireless.com
root@swi-mdm9x15:~# cm data
Index: 1
APN: internet.sierrawireless.com
PDP Type: IPV4V6
Connected: no
root@swi-mdm9x15:~# cm data connect
Setting up profile 1
Setting access point name … ok
Setting packet data protocol … ok
Setting Authentication … ok
Connecting … ok
Checking if device is up … ok
Routing … ok
Updating /etc/resolv.conf … ok
Updating /etc/resolv.conf … ok
Testing connection … ok

cm radio
Power: ON
Current Network Operator: T-Mobile
Current RAT: UMTS network (LE_MRC_RAT_UMTS)
Status: Registered to a roaming network (LE_MRC_REG_ROAMING)
Signal: Strong signal strength (4)
PS: Packet Switched Registered, home network (LE_MRC_REG_HOME)

I then started the RedSensorToCloud app and it is sending data to the air vantage : I can see the sensor data on the website. Perhaps try switching the PDP type to IPV4V6? You could also try popping in another sim card. If you have an ATT sim card, you use the “phone” apn. If you have another carrier, then you will have to google what the apn is for that carrier. Let me know if you need any more information.