MangOH Red Not Transmitting

Hello,

I have started working through the new getting started guide (non-octave) for my device. I have reached the step where I am to start redCloud. After this is done, there is no sensor data on my AirVantage account. Any help would be greatly appreciated.

Thanks

seems you can make it work in the past:

I recently started the device up again, and now the issue persists.

Not sure what have you done before. Maybe u
You can check the sensor driver and app log

How do I check the sensor driver and app log?

Please see if you can see the sensor value, e.g.
cat /sys/bus/i2c/devices/4-0068/iio:device0/in_anglvel_x_raw
cat /sys/bus/i2c/devices/4-0068/iio:device0/in_temp_raw

For the app log, you can see in “logread -f”

Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘accel’ expired
Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘gyro’ expired
Mar 18 00:28:55 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushAcceleration() 496 | Failed to push to AirVantage Agent (LE_FAULT).
Mar 18 00:28:55 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushJson() 805 | LE_FAULT: Delivery of ‘/obs/accel’ stalled.
Mar 18 00:28:55 swi-mdm9x28-wp user.warn Legato: -WRN- | cloud[2591]/avPublisher T=main | avPublisher.c HandleAvPushComplete() 225 | Push to AirVantage failed (/obs/accel). Retrying…
Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘position’ expired
Mar 18 00:28:55 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushAngularVelocity() 585 | Failed to push to AirVantage Agent (LE_FAULT).
Mar 18 00:28:55 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushJson() 805 | LE_FAULT: Delivery of ‘/obs/gyro’ stalled.
Mar 18 00:28:55 swi-mdm9x28-wp user.warn Legato: -WRN- | cloud[2591]/avPublisher T=main | avPublisher.c HandleAvPushComplete() 225 | Push to AirVantage failed (/obs/gyro). Retrying…
Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c RestartTimerPhys() 289 | timer ‘pressure’ started
Mar 18 00:28:55 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushPosition() 703 | Failed to push to AirVantage Agent (LE_FAULT).
Mar 18 00:28:55 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushJson() 805 | LE_FAULT: Delivery of ‘/obs/position’ stalled.
Mar 18 00:28:55 swi-mdm9x28-wp user.warn Legato: -WRN- | cloud[2591]/avPublisher T=main | avPublisher.c HandleAvPushComplete() 225 | Push to AirVantage failed (/obs/position). Retrying…
Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘pressure’ expired
Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘pressure/temp’ expired
Mar 18 00:28:55 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c RestartTimerPhys() 289 | timer ‘light’ started
Mar 18 00:28:56 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘light’ expired
Mar 17 17:28:56 swi-mdm9x28-wp user.err kernel: [ 2773.041901] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
Mar 17 17:28:56 swi-mdm9x28-wp user.err kernel: [ 2773.056695] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
Mar 17 17:28:56 swi-mdm9x28-wp user.info kernel: [ 2773.105031] gpio_check_and_wake: wake-n_gpio26 STATE=WAKEUP
Mar 17 17:28:56 swi-mdm9x28-wp user.info kernel: [ 2773.120026] gpio_check_and_wake: wake-n_gpio26 STATE=SLEEP
Mar 18 00:28:56 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c RestartTimerPhys() 289 | timer ‘accel’ started
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘accel’ expired
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘gyro’ expired
Mar 18 00:29:05 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushAcceleration() 496 | Failed to push to AirVantage Agent (LE_FAULT).
Mar 18 00:29:05 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushJson() 805 | LE_FAULT: Delivery of ‘/obs/accel’ stalled.
Mar 18 00:29:05 swi-mdm9x28-wp user.warn Legato: -WRN- | cloud[2591]/avPublisher T=main | avPublisher.c HandleAvPushComplete() 225 | Push to AirVantage failed (/obs/accel). Retrying…
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘position’ expired
Mar 18 00:29:05 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushAngularVelocity() 585 | Failed to push to AirVantage Agent (LE_FAULT).
Mar 18 00:29:05 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushJson() 805 | LE_FAULT: Delivery of ‘/obs/gyro’ stalled.
Mar 18 00:29:05 swi-mdm9x28-wp user.warn Legato: -WRN- | cloud[2591]/avPublisher T=main | avPublisher.c HandleAvPushComplete() 225 | Push to AirVantage failed (/obs/gyro). Retrying…
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c RestartTimerPhys() 289 | timer ‘pressure’ started
Mar 18 00:29:05 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushPosition() 703 | Failed to push to AirVantage Agent (LE_FAULT).
Mar 18 00:29:05 swi-mdm9x28-wp user.crit Legato: CRT | cloud[2591]/avPublisher T=main | avPublisher.c PushJson() 805 | LE_FAULT: Delivery of ‘/obs/position’ stalled.
Mar 18 00:29:05 swi-mdm9x28-wp user.warn Legato: -WRN- | cloud[2591]/avPublisher T=main | avPublisher.c HandleAvPushComplete() 225 | Push to AirVantage failed (/obs/position). Retrying…
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘pressure’ expired
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘pressure/temp’ expired
Mar 18 00:29:05 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c RestartTimerPhys() 289 | timer ‘light’ started
Mar 18 00:29:06 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c ProcessExpiredTimer() 392 | Timer ‘light’ expired
Mar 17 17:29:06 swi-mdm9x28-wp user.err kernel: [ 2783.041819] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
Mar 17 17:29:06 swi-mdm9x28-wp user.err kernel: [ 2783.056635] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
Mar 17 17:29:06 swi-mdm9x28-wp user.info kernel: [ 2783.104938] gpio_check_and_wake: wake-n_gpio26 STATE=WAKEUP
Mar 17 17:29:06 swi-mdm9x28-wp user.info kernel: [ 2783.121863] gpio_check_and_wake: wake-n_gpio26 STATE=SLEEP
Mar 18 00:29:06 swi-mdm9x28-wp user.debug Legato: DBUG | redSensor[1716]/framework T=main | timer.c RestartTimerPhys() 289 | timer ‘accel’ started
^C
root@swi-mdm9x28-wp:~#

for temp i get the value of 2095

In the log I just posted, I noticed that the message “Push to AirVantage failed” appears frequently. Is there some way to fix that?

Please see if you can see the sensor value, e.g.
cat /sys/bus/i2c/devices/4-0068/iio:device0/in_anglvel_x_raw
cat /sys/bus/i2c/devices/4-0068/iio:device0/in_temp_raw

Did you register the module in avms website?

you need to type AT+WDSS=1,1 in /dev/ttyAT to connect to Airvantage server.

the temperature reading is 2840

I typed in the AT+WDSS=1,1 as well.

What did you see in the monitor view in avms

there is data in the last communication area, but none of the data makes sense. also, none of the data in last communication is posted in the graphs below. The graphs read ‘no data’

Can you capture the screen

then that means it is working fine that data is sent to the AVMS server if you confirm the date is correct.

the date is correct, but none of the data is being printed on the graphs, per the manual

then is it back to the same problem as this thread?

if yes, then that means the mangoh red can transmit data, just cannot display on your graph.

Yes. Back then i uploaded that zip file but nothing changed.