mangOH Red not seen by PC


#1

My mangOH red is not seen at all by the PC when the the CM3 USB is plugged in;
nothing at all happens in Device Manager - not even any “unrecognised” devices.

The Console connection works, and I can see that Legato is starting.

Above is on Win7-Pro; similarly with Ubuntu - no additional ttyUSB devices appear when the mangOH is plugged in.

I have tried via a USB hub, and direct into the PC.


#2

You say the Console connection works… do you mean using the Console USB connector?

Are you using two usb cables (one in each connector), or one usb cable in either Console USB or CF3 USB?

If only one cable, when you tried to use the CF3 USB connector, did you make sure to move the jumper on the POWER header to select the CF3 USB?


#3

Yes: Console via Console USB connector, and a second USB cable to the CF3 USB.


#4

Have you tried plugging the CF3 USB into different ports on your development computer? Maybe you have a dead port.


#5

As dfrey noted, could be a dead port.
Could also be a bad cable from CF3 to PC.
Could be bad CF3 connector.

  1. Try David’s suggestion first.

If that doesn’t work:

  1. Remove cable from CF3 USB connector
  2. Remove cable from Console USB connector (we’re going to use this one in a moment, because we know it’s a ‘good’ cable)
  3. Move jumper on power header to the pair of pins closest to the battery connector. (this selects CF3 USB for power supply)
  4. Connect the cable to CF3 USB (make sure it’s seated correctly) and to the PC.

Did the Power LED come on? If not, then the connector seems to be dead. Disconnect and try again (making sure it’s seated properly).

If the power LED does come on, then see if it’s enumerating on the PC.

If it is, then the problem was either the cable or the cable not sitting properly.

If it’s not enumerating… let’s cross that bridge when we come to it :slight_smile:


#6

or reinstall the CF3 drivers


#7

Yes: different ports (USB3 and USB2) on the same computer, and via a hub on the same computer.

Also the same behaviour on a different computer.


#8

also tried re-installing the CF3 drivers: initially build 4653 - linked from https://mangoh.io/mangoh-red-resources-getting-started - and then build 4762.

and tried restarting the PC.


#9

are u coming to the Summit? :slight_smile:


#10

The jumper was already on the pair of pins closest to the battery connector.

LED lights.

Removing the cable previously on CF3, and using the one that worked for the Console instead - still no enumeration.

LED still lights.

If I now use the other cable for the Console connection, I again see the console output

I think we have come to it …


#11

Yes - I am coming to the Summit!


#12

Have you ever successfully connected to this module before? And if so… did you happen to experiment with an AT command to enable/disable interfaces?

If you haven’t turned interfaces on/off (which if done incorrectly could turn off all of them?) … then we need someone to help cross this bridge :slight_smile:

We’ve eliminated (I believe) as a cause:
– pc connection
– cable
– cable to cf3 usb (seating properly)
– [cf3 usb connector pins other than power] <— possible source of issue?
– cf3 drivers

Problem could be with the connector (as noted above) – it’s getting power, but maybe the issue could be with the data pin(s)?

Hopefully someone can weigh in with a brainstorm (I’m stuck).


#13

No - this is first attempt!

Is there an AT command (or commands) to check that all interfaces are enabled?


#14

You noted that you get the console output when the module boots.
Could you post the output here?


#15

Sure: COM23-20180530-1425a.log (78.5 KB)

the last bit juts keeps repeating …


#16

What module is it? When did you get it?


#17

It was one from the Summit last year


#18

That was not the final launch hardware and a dev board. Many changes were done to that.


#19

but basic essentials - like the USB connection - should work … ?