MangOH Red No Power


My MangOH Red had been working fine up until Friday evening. I plugged the USB cord into the computer and then into the CF3 micro USB port but no power. I tried restarting the computer, thinking that maybe the USB ports on the computer were acting up, but still nothing. I plugged the USB cord into the console micro USB and had connection, but, of course, I was unable to ping the MangOH. I did check for voltage coming from the computer to the board and there is voltage. Any thoughts would greatly be appreciated.

UPDATE…It seems that the culprit is the cellular module WP8548; I replaced the one I had in the board with a WP7504 just to check if power would come on and it did. I will have to put in another WP8548 and see if I can pick up where I left off.
Here is an image of the last communication from the MangOH Red before its untimely demise…


Try to install the same WP85 again. Maybe the module cover was loose.


Unfortunately, that didn’t work. I tried the module on a different MangOH Red as well but still no power.