MangoH Red No Carrier issue

Hello,

I recently got my MangoH red and started using a Vodafone sim. I am trying to call using atd1234567 command in Microcom /dev/ttyAT. But I am always getting NO CARRIER notification.

root@swi-mdm9x28-wp:~# microcom /dev/ttyAT 
ati3
Manufacturer: Sierra Wireless, Incorporated
Model: WP7607
Revision: SWI9X07Y_02.28.03.05 000000 jenkins 2019/07/08 11:04:16
IMEI: 359779080124634
IMEI SV:  6
FSN: VN842200870113
+GCAP: +CGSM

OK
atd1234567
NO CARRIER
at+cops=?
+cops: (2,"vodafone.de","vodafone","26202",7),(1,"Vodafone.de","Vodafone","26202",2),(1,"Vodafone.de","Vodafone","26202",0),(3,"o2 - de","o2 - de","26203",7),(3,"Telekom.de","TDG","26201",2),(3,"o2 - de","o2 - de","26203",0),(3,"o2 - de","o2 - de","26203",2),(3,"Telekom.de","TDG","26201",7),(3,"Telekom.de","TDG","26201",0),,(0,1,2,3,4),(0,1,2)

OK
at+cops?
+cops: 1,2,"26202",7

OK

+CMTI: "SM",8

+CMTI: "SM",8
atd1234567
NO CARRIER

Any help to troubleshoot this error will be appreciated.

Thanks

You need to type this in usb AT command port, also you missed the colon at the end

Hello @jyijyi, thanks for your reply. Can you explain a bit more. I am currently connected to the board and using the VM via USB. I have started the microcom /dev/ttyAT on the board. I also tried ATD1234567; now it shows ERROR.
cm data is connected.

when you connect the module to the VM, there should be /dev/ttyUSB0-2 enumerated.
/dev/ttyUSB2 is the USB AT command port.
You should type the ATDxxxxxxx; in this port.

I am not getting the /dev/ttyUSB2 port on the VM when the board is connected.

mangoh@mangoh-vm:~$ dmesg | grep tty
[    0.004000] console [tty0] enabled
mangoh@mangoh-vm:~$ microcom /dev/tty
tty        tty20      tty33      tty46      tty59      ttyS12     ttyS25
tty0       tty21      tty34      tty47      tty6       ttyS13     ttyS26
tty1       tty22      tty35      tty48      tty60      ttyS14     ttyS27
tty10      tty23      tty36      tty49      tty61      ttyS15     ttyS28
tty11      tty24      tty37      tty5       tty62      ttyS16     ttyS29
tty12      tty25      tty38      tty50      tty63      ttyS17     ttyS3
tty13      tty26      tty39      tty51      tty7       ttyS18     ttyS30
tty14      tty27      tty4       tty52      tty8       ttyS19     ttyS31
tty15      tty28      tty40      tty53      tty9       ttyS2      ttyS4
tty16      tty29      tty41      tty54      ttyprintk  ttyS20     ttyS5
tty17      tty3       tty42      tty55      ttyS0      ttyS21     ttyS6
tty18      tty30      tty43      tty56      ttyS1      ttyS22     ttyS7
tty19      tty31      tty44      tty57      ttyS10     ttyS23     ttyS8
tty2       tty32      tty45      tty58      ttyS11     ttyS24     ttyS9
mangoh@mangoh-vm:~$ microcom /dev/tty

From what I read in the forums. microcom /dev/ttyAT on the board should also be able to complete atd1234567; command?
I tried also the modemDemov example, but that also fail to send a message.

I think you need to install usb driver in linux

https://source.sierrawireless.com/resources/airprime/software/usb-drivers-linux-qmi-software-s2,-d-,42n2,-d-,64/

I installed the qmi driver, GobiNet and GobiSerial and power cycled the board to check the the /dev/ttyUSB connection. But still can’t find the board any way of troubleshooting this?

Go to microcom, check
At!entercnd=“A710”
At!usbcomp?
At!usbcomp=?

It gives an error for all three commands.

root@swi-mdm9x28-wp:~# microcom /dev/ttyAT 
at
OK
At!entercnd=“A710”
ERROR
At!usbcomp?
ERROR
At!usbcomp=?
ERROR

At!entercnd=“A710” should return OK, can you try one more module

Do you mean another module? I currently have only one mangoH Red.

“A710” the double quote should be "

Ah sorry yea it works.

root@swi-mdm9x28-wp:~# microcom /dev/ttyAT 
AT
OK
At!entercnd="A710"
OK
At!usbcomp?
Config Index: 1
Config Type:  1 (Generic)
Interface bitmask: 0008010D (diag,nmea,modem,rmnet0,ecm) 

OK
at!usbcomp=?
!USBCOMP: 
AT!USBCOMP=<Config Index>,<Config Type>,<Interface bitmask>
  <Config Index>      - configuration index to which the composition applies, should be 1

  <Config Type>       - 1:Generic
  
  <Interface bitmask> - DIAG     - 0x00000001,
                        NMEA     - 0x00000004,
                        MODEM    - 0x00000008,
                        RAWDAT   - 0x00000040,
                        RMNET0   - 0x00000100,
                        RMNET1   - 0x00000400,
                        RMNET2   - 0x00000800,
                        AUDIO    - 0x00010000,
                        ECM      - 0x00080000,
                        NCM      - 0x00400000,
  e.g.
  9  - diag,modem interfaces enabled
  10D - diag,nmea,modem,rmnet0 interfaces enabled

OK

then the modem port is enabled.
Can you plug into Windows and see if you can see the modem port in device manager?

Yes, on device manager Windows:

Sierra wireless DM port (COM6)
Sierra Wireless NMEA Port (COM5)

It also shows the WWAN modem, Legato EthLink ECM and network adapter.

open the modem port with tera term or putty and then type ATD1234567;

image

It gives the same error.
Capture

What is the return of

At!gstatus?

image

Is the sim ok for voice call?
I saw that ims is not registered, not sure if you need special apn