Mangoh red mt7697 patches still needed?


I’m working to connect a mangoh red with WP76 series to my home wifi network and am trying to use the built-in wifi. I have been following the instructions from and have gotten all the way to the legato patching section. My question is that after I clone the legato patch folder, there is no folder for the newer releases. Does this mean that the newer releases have already been patched or does it mean that no one has updated the scripts for the patches for newer releases? I’m currently working off the mangoh-red-wp76xx_0.5.0 mangOH Red wp76 - FW=R13.3, Legato=19.11.0 release.

I remember i had tried on R9 and it works, you might try on that.

I just have compared between the patched legato version 19.01.0 and the R13 legato 19.2, seems the patch is not integrated.
So I suggest you tried on R9.

I was doing further reading this time on the readme file for the Mangoh Yellow cypress wifi chip and it seems that even the same patch is needed for the mangoh Yellow:

From: mangOH/linux_kernel_modules/cypwifi

Please apply the Legato Patches as mentioned under:

  • /legato/systems/current/modules/files/brcmutil/etc/init.d/ init

Does anyone know how to make the patch available for R13?

If I wanted to try an older release, how do I even get it? I see in the leaf repository, that the oldest I can get for mangOH red is :
│ mangoh-red-wp76xx_0.5.0 │ mangOH Red wp76 - FW=R13.3, Legato=19.11.0, Octave=2.1.2-mangOH-0

you can search all the package by “leaf search”, and then you will see there is some old packages for WP76 modules.

swi-wp76_4.0.3 -> SDK for WP76 (Release 13.3 + Legato 19.02.0)

BTW, I think you can try legato 19.1.0 as there is legato patches for this version

Thanks, I have gotten that package and applied the patches. But I’m still facing issues when trying to bring wlan1 up.

root@swi-mdm9x28-wp:/etc/network# ifup wlan1
Setup MT7697 UART
Device: WP76
Enable power control
insmod: can’t insert ‘/legato/systems/current/modules/mt7697wifi_core.ko’: No such file or directory

I’m thinking that this is because possibly the drivers for the mt7697 chip are not being loaded properly into the board. I have seen other forum posts historically that are concerned about the following statements when running the build:

make[2]: Entering directory '/home/mangodev/.leaf/wp76-toolchain_SWI9X07Y_02.18.06.00-linux64/sysroots/armv7a-neon-poky-linux-gnueabi/usr/src/kernel'
  CC [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/wmi.o
  CC [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/cfg80211.o
  CC [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/main.o
  CC [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/txrx.o
  CC [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/ioctl.o
  LD [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: "mt7697q_read" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697_uart_read" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697q_shutdown" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697_uart_close" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697_uart_write" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697q_unblock_writer" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697_uart_open" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697q_write" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
WARNING: "mt7697q_init" [/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko] undefined!
  CC      /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.mod.o
  LD [M]  /home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core/mt7697wifi_core.ko
make[2]: Leaving directory '/home/mangodev/.leaf/wp76-toolchain_SWI9X07Y_02.18.06.00-linux64/sysroots/armv7a-neon-poky-linux-gnueabi/usr/src/kernel'
make[1]: Leaving directory '/home/mangodev/mangoh/leaf-data/mangohRED_19_01_0/mangOH/build/red_wp76xx/modules/mt7697wifi_core'

FYI, i have also used an older repository of mangoh hoping that the more recent changes made didn’t break the wifi. I’m running mango repository:

HEAD detached at f9c1bba

If i look at the script for the mangoh build, I see that only cypress wifi is being built for the yellow. The file inside the folder mt7697wifi is never exectuted. When I execute manually, I get a bunch of errors because the directories referenced in the build script are not on my machine and I don’t know where to point them to.

I can see mt7697wifi_core is include in red.sdef