mangOH Red lost 192.168.2.2 IP & MT7697 Setup


#1

Hi,

I got my new mangOH Red WP7608 boards last week.

We need to get the mangOH running as a server on a known TCP or a HTTP port to receive data from an exernal Wi-Fi Client. We dont want to add any other wifi router to bring them into a network, since the participants in the network are only these two. We leant that WP7608 can be configured to AP mode. And we want the other device get into this wifi network to get an IP address and connect to it.

I was trying to set the AP mode using wifiWebAp already installed on the board.

I started the app and opened the browser with 192.168.2.2:8080.
It opened a page to configure and set the device in AP mode. I started it with the default settings.
I scanned for the WiFi AP on my mobile and PC but nothing found with the default SSID configured nor there was a sign of a new Wifi ap. I tried to stop and start a couple of times but no avail.
Later turned off the device.
Today when powered the board, it lost the CF3 port IP address (192.168.2.2). When checked for ‘ipconfig /all’ on the host (windows 10), I get this (But earlier I used to see the ECM adapter with good IP)
Ethernet adapter Ethernet 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Sierra Wireless LEGATO EthLink ECM #2
Physical Address. . . . . . . . . : 16-0E-D3-FC-1C-DC
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::55bc:a980:2a8c:2b19%52(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.43.25(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 878890225
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-28-61-85-C0-25-E9-27-2D-8F
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled
I tried to reboot it a few times but it won’t get the default IP of 192.168.2.2. Seems like It got stuck somewhere.

Please suggest if anyone has a solution for this to get it back or a process to reset the device.

Thanks
Madan


#2

The board was already flashed with WP76xx_Release9_GENERIC_EXE. So I guess it would have had latest firmware to run wifi.


#3

I tried to connect from the console port. luckily console port works. “ifconfig” gives me the output below.
I am seeing 2 additional network adapters - probably because of executing the “wifiWebAp” tool earlier.

How can I reset them, to get back to original state?


root@swi-mdm9x28:~# ifconfig
ifconfig
bridge0 Link encap:Ethernet HWaddr 5A:77:5F:07:5B:43
inet addr:192.168.225.1 Bcast:192.168.225.255 Mask:255.255.255.0
inet6 addr: fe80::5877:5fff:fe04:5840%1341333244/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:76 (76.0 B)

ecm0 Link encap:Ethernet HWaddr E2:C6:7A:C5:A1:01
inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1%1341333244/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

rmnet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:2000 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


#4

@fgodfrey @asyal can someone help me on this please?

The board is flashed with Firmware 9 release. I used the wifiWebAp application to set the device in AP mode. However, it did not work. I mean I could get the AP on any client devices. I turned the device off and left. When I powered it again, I faced this issue. I guess the WiFi settings the wifiWebAp made are stuck in there, which could be causing the issue. Is there a way to reset this stuff?
I can access the device from the console port.

Our Idea to use the mangOH as an AP, is to create a private network between a client and this.
BTW, I had gone through the Video on setting up the device for WiFi (we are not using IOT card). That means the procedure for MT7697 to be followed. Should I really have to do MT7697 firmware upload because I already flashed the device with Release 9.

Please help me with the issue and the WiFI configuration.
Thanks.


#5

cm info
Device: WP7608
IMEI: 352913090103282
IMEISV: 4
FSN: XG814285220710
Firmware Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
Bootloader Version: SWI9X07[ 99.606759] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x001363c8 OPER:0x00000090
Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
MCU Version: 002.009
PRI Part Number (PN): 9907762
PRI Revision: 001.002
Carrier PRI Name: GENERIC
Carrier PRI Revision: 002.032_000
SKU: 1103788
Last Reset Cause: Power Down
Resets Count: Expected: 30 Unexpected: 1


#6

Hello Madan,

See this post : Brand new WP7603 working, reboot and inaccessible via ssh

This might be the same problem that I had.

Have a nice one


#7

The WiFi chipset does not get programmed when you flash the board - it’s a separate flash. So, yes, you need to follow the procedure. I assume at some point, they’ll have it pre-flashed but at least on my MangOH Red, it was blank when I got the board from DigiKey.

I’m on older Sierra/mangOH software so I haven’t seen the web app, but this has no hope of working until you follow the MediaTek programming.

Those network ports (rmnet0 and the bridge) are always there. I honestly am not sure what the bridge is used for, but I believe the rmnet0 port is used for cellular data. You’ll see a wlan1 interface when you finally get the MT7697 programmed and get the right Linux drivers loaded on the WP76xx.

You’ll note that ecm0 does, in fact, have 192.168.2.2 assigned to it. I suspect that what has happened is the when you configured the WiFi for access point mode, it somehow messed up the DHCP server that serves the fake Ethernet to the USB port. I had this happen once but I’m not sure how I fixed it (it seemed to fix itself). In the mean time, I manually gave my laptop an IP address for it. The following settings should work: IP address: 192.168.2.1, subnet mask 255.255.255.0. Note that the subnet mask for your laptop (or whatever your host is) isn’t the same as the one for the MangOH. I did that on purpose because a lot of WiFi networks are in that range and I don’t want to cause you conflicts. If you’re comfortable with IP networks, you can choose whatever you think will work.


#8

Hey Kim,

Thanks for your note. I have tried deleting the /etc/dnsmasq.d/dnsmasq.wlan.conf and rebooting. Unfortunately, it did not bring up the CF3 USB IP address.

Thanks anyways.


#9

Thanks Godfrey.
Yes, I did suspect that there could be some conflict with DHCP and the USB fake IP assignment.
As you suggested, I have assigned a 192.168.2.1. THAT WORKED. Now, I am able to connect to 192.168.2.2. and even can do SSH into it.

I tried now again to reflash the firmware. It was successful. However, I could not get the IP address by default, unless I configure a static IP to the ECM interface. For now, I think that should be fine.

Coming to flashing the MT7697—>
I found there is a 4.6.1 SDK on the Mediatek site and downloaded that. And followed the steps given. However, both step 6 and 7 had some errors. So, downloaded the 4.3.0 SDK. Steps 1 thru 7 went through. But the build failed. Not sure why.
I am running this on the mangOH development VM. So I assume the GCC and other tools should work.

I found that VM already has the MediaTek SDK installed and built and as well as the flash tool. I would give it a try with that and let you know how it goes.

Thanks for the support.

Madan


#10

Hi

I tried building LinkIt_SDK_V4.3.0_public. I am getting this build failure error. Any ideas why this build is failing?

GCC tools are available in ~/LinkIt_SDK_V4.3.0_public/tools/gcc/gcc-arm-none-eabi/arm-none-eabi/bin/.

Build… syscalls.o FAIL
Build… lzma_decode_interface.o
Build… lzma_decode_interface.o FAIL
Build… lzma_decoder.o
Build… lzma_decoder.o FAIL
Build… verno.o
Build… verno.o FAIL
Linking…
Makefile:169: recipe for target ‘/home/mangoh/LinkIt_SDK_V4.3.0_public/out/linkit7697_hdk/MT7697_WiFi_BT_fw/mt7697_bootloader.elf’ failed
make: Leaving directory ‘/home/mangoh/LinkIt_SDK_V4.3.0_public/project/linkit7697_hdk/apps/bootloader/GCC’
Error: bootloader build failed!!

Thanks
Madan


#11

Do the various logs have any useful clues?

My build area has these logs:
./out/linkit7697_hdk/MT7697_WiFi_BT_fw/log
./out/linkit7697_hdk/MT7697_WiFi_BT_fw/log/build_time.log
./out/linkit7697_hdk/MT7697_WiFi_BT_fw/log/err.log
./out/linkit7697_hdk/MT7697_WiFi_BT_fw/log/build.log


#12

Hi @fgodfrey,

Thanks for your response and support.

This may be a shortcut I tried, assuming that the mangoh-vm had the prebuilt MediaTek binaries.

Here is the procedure I followed (as per the video).

Dip Switch - 1,2,3,5,6,8 Up
COnnected to console port…verified that it dumps CCCCCC…

Copied From VM - ~/MediaTek_LinkIt_SDK_V4.3.0_public/out/linkit7697_hdk/MT7697_WiFi_BT_fw
flash_download.ini
WIFI_RAM_CODE_MT76X7_in_flash.bin
Copied From VM - ~/MediaTek_LinkIt_SDK_V4.3.0_public/project/linkit7697_hdk/apps/bootloader/GCC
bootloader.bin
Renamed bootloader.bin to mt7697_bootloader.bin (cause flash_download.ini is refering to this file name)

The dates of these files are around April, May this year.

Uploaded the files using the Mediatek upload tool. It was successful.

Dip Switch - 1,3,5,8 Up

executed the following commands:
microcom /dev/ttyAT
at!mapuart=17,1…OK
at+wiocfg=2,16…OK
at+wiocfg=8,16…OK
at+wiocfg=13,16…OK
exit

Initially, I did not find ‘/dev/ttyHS0’ and ‘/dev/ttyHSL1’. But after executing above commands they are visible.

Copied the contents of script files as suggested in the video. (interfaces, mtwifi) and given execute permissions

Now checked ifconfig…no sign of wlan1.
Executed - ‘ifup wlan1’

root@swi-mdm9x28:~# /sbin/ifup wlan1
Setup MT7697 UART
Device: WP76
Enable power control
Initialized Linux WiFi modules
Initialized MT7697 WiFi core
Failed to init MT7697 WiFi core
root@swi-mdm9x28:~#

I think the script is trying to run ‘ifconfig’ to get wlan1 interface, which is not there yet.

What did I miss here? Please suggest.

I tried this on 2 mangOH Reds I have. One had the USB IP issue and the other was all good. both were upgraded to Release9 prior to this and legato updated as well (RedtoCloud is there).

Best regards.
Madan


#13

As I said earlier, the GCC tools are there.

This is the error log.
/bin/sh: line 6: …/…/…/…/…/tools/gcc//gcc-arm-none-eabi/bin/arm-none-eabi-gcc: No such file or directory

/bin/sh: line 6: …/…/…/…/…/tools/gcc//gcc-arm-none-eabi/bin/arm-none-eabi-gcc: No such file or directory

/bin/sh: line 6: …/…/…/…/…/tools/gcc//gcc-arm-none-eabi/bin/arm-none-eabi-gcc: No such file or directory

/bin/sh: line 6: …/…/…/…/…/tools/gcc//gcc-arm-none-eabi/bin/arm-none-eabi-gcc: No such file or directory

I am just doubting the parent directory it is pointing to.


#14

Hmm. Well, obviously, the build isn’t finding the compiler for some reason. This “just worked” for me so I’m not sure why yours isn’t.

As for the “ifup” problem… If you look at the ifup script for wlan1, you’ll notice that the “Initialized Linux WiFi modules” step is loading 3 kernel modules. After that, if everything is working, wlan1 should appear. To debug that, probably the most useful thing to try first is “dmesg” to see if there are any obvious errors. I think the most likely scenario, unfortunately, is that the prebuilt binary you used is not compatible with the version of the Linux kernel modules you have.


#15

Hi @fgodfrey, Thank you for your response and support on this.

First, I could not get a reason why the Build is failing, even though I tried to pass the absolute path to the gcc.
Also, tried removing an additional ‘/’ here ‘/tools/gcc//gcc-arm-none-eabi’.

Second, here is the log from dmesg for mt7697 and failed.

My guess here is that probably mt9697 is unable to attach to the UART properly or UART is not initialized.

root@swi-mdm9x28:~# dmesg | grep mt7697
[ 17.620300] mt7697q mt7697spi_init(): ‘mt7697q’ initialize
[ 17.754130] spi_master spi32766: mt7697spi_init(): find SPI device(‘spi32766.0’)
[ 17.754157] spi_master spi32766: mt7697spi_init(): dev(‘mt7697’) mode(0) max speed(12000000) CS(0) bits/word(8)
[ 17.760922] spi spi32766.0: mt7697spi_init(): request irq(60)
[ 17.761095] spi spi32766.0: mt7697spi_init(): ‘mt7697q’ initialized
[ 17.803865] mt7697serial init
[ 17.804551] mt7697serial mt7697serial: mt7697_uart_probe(): init
[ 17.804572] mt7697serial mt7697serial: mt7697_uart_probe(): ‘mt7697serial’ initialized
[ 114.784912] mt7697core init
[ 114.787727] mt7697_uart_open(): find UART device(‘mt7697serial’)
[ 114.787899] mt7697serial mt7697serial: mt7697_uart_open(): open serial device ‘/dev/ttyHS0’
root@swi-mdm9x28:~# dmesg | grep failed
[ 0.658599] msm_serial_hsl: probe of 78b0000.serial failed with error -1
[ 0.819543] coresight-cti: probe of 6010000.cti failed with error -1
[ 0.819588] coresight-cti: probe of 6011000.cti failed with error -1
[ 0.819627] coresight-cti: probe of 6012000.cti failed with error -1
[ 0.819666] coresight-cti: probe of 6013000.cti failed with error -1
[ 0.819706] coresight-cti: probe of 6014000.cti failed with error -1
[ 0.819744] coresight-cti: probe of 6015000.cti failed with error -1
[ 0.819783] coresight-cti: probe of 6016000.cti failed with error -1
[ 0.819822] coresight-cti: probe of 6017000.cti failed with error -1
[ 0.819860] coresight-cti: probe of 6018000.cti failed with error -1
[ 0.819900] coresight-cti: probe of 6043000.cti failed with error -1
[ 0.819939] coresight-cti: probe of 603c000.cti failed with error -1
[ 0.819978] coresight-cti: probe of 6038000.cti failed with error -1
[ 0.821040] coresight-tmc: probe of 6026000.tmc failed with error -1
[ 0.821161] coresight-tmc 6025000.tmc: failed to get flush cti
[ 0.821175] coresight-tmc 6025000.tmc: failed to get reset cti
[ 0.833368] coresight-stm: probe of 6002000.stm failed with error -1
[ 0.860437] coresight-etm: probe of 6042000.etm failed with error -22
[ 17.320480] pca954x 4-0071: lookup for GPIO reset failed
[ 17.430687] bmp280 4-0076: lookup for GPIO reset failed
root@swi-mdm9x28:~#

We are not able to move forward with these issues any further on our project and time is running out.

Could you please suggest the steps to get the wifi enabled, given that the boards are running Release 9 firmware.
Or when can a mangoh firmware release with mt7697 firmware integrated, be expected?
Or, Will you be able help me with the compiled bin files for MT7697 for Release9 Kernel?

Appreciate your support in moving this forward.

Thank you
Madan


#16

Hmm. There’s no software releases that roll in the MT7697 firmware. I suspect that’s because of the difficulty in getting it flashed (with having to move the DIP switches, etc). It looks to me like maybe your device isn’t properly flashed since there should be a bunch of messages after your last one where it opens the serial device. I think I’m about out of ideas on this one. Hopefully the various MangOH/Sierra employees who answer questions here can provide something better (I’m just another end user). For me, this stuff “just worked”.


#17

Sure, I will try to reach out to mangOH team, if they can suggest a way.

By the way, what was the firmware version you had with the successful WiFi configuration?


#18

My software is a bit older than yours.

I have:

  • Firmware Release 8 for the WP7702 module
  • LinkIt SDK version 4.3
  • MangOH Drivers as of Git Hash 4a9ce3c3fad91a7a5fe4acfbe30480c55b7a18a3
  • MangOH MT7697 Software as of Git Hash 5c0d3f1ce5c95c8169cf3c1855a945a174fd1812

#19

Got connected with a local TAE. He provided me the binaries for MT7697 and mangOH.

After uploading them, I am able to run ‘ifup wlan1’ and got the wlan1 enabled.

I tried to configure my wifi router but couldn’t make a successful connection. Same is with mobile hotspot as well.

Not sure why.


#20

After you did ifup wlan1, what did you do? Were you able to perform a scan using iw dev wlan1 scan?