Mangoh Red Crashes after Stopping audioService


#1

The Problem

If I stop the audioService component with the following command, it is successful, but the MangohRed consistently crashes after a few minutes. My ssh session is terminated, and I can see from the power monitor that the board goes through a reboot immediately.

$ app stop audioService

Any Idea why this might happen?

My Environment (before executing any commands)

root@swi-mdm9x28:~# legato version
18.01.0-1-g88cc096_c6f2cf49aed9ec950070144722658a4d

root@swi-mdm9x28:~# cm info
Device: WP7603
IMEI: 357409080008909
IMEISV: 3
FSN: U3734285531306
Firmware Version: SWI9X07Y_02.10.01.00 000000 jenkins 2017/12/03 03:05:33
Bootloader Version: SWI9X07Y_02.10.01.00 000000 jenkins 2017/12/03 03:05:33
MCU Version: 002.007
PRI Part Number (PN): 9906965
PRI Revision: 002.001
Carrier PRI Name: ATT
Carrier PRI Revision: 002.015_001
SKU: 1103194
Last Reset Cause: Unknown
Resets Count: Expected: 79 Unexpected: 12

root@swi-mdm9x28:~# fwupdate query
Connecting to service …
Firmware Version: SWI9X07Y_02.10.01.00 000000 jenkins 2017/12/03 03:05:33
Bootloader Version: SWI9X07Y_02.10.01.00 000000 jenkins 2017/12/03 03:05:33
Linux Version: 3.18.44 #2 PREEMPT Wed Feb 14 21:24:42 UTC 2018

root@swi-mdm9x28:~# app status
[running] atService
[running] audioService
[running] avcService
[stopped] batteryService
[running] cellNetService
[running] dataConnectionService
[stopped] dataPushTest
[running] dataRouter
[running] devMode
[stopped] drTool
[running] fwupdateService
[running] gpioService
[stopped] ledService
[running] modemService
[running] mqttClient
[running] portService
[running] positioningService
[running] powerMgr
[stopped] redSensorToCloud
[running] secStore
[stopped] smsInboxService
[stopped] socialService
[stopped] spiService
[stopped] tools
[stopped] voiceCallService
[stopped] wifi
[stopped] wifiApTest
[stopped] wifiClientTest
[running] wifiService
[stopped] wifiWebAp
root@swi-mdm9x28:~#


#2

I think I may have discovered the reason… It looks like disabling the audioService is not supported because the watchdog will restart the device?

Jan 6 00:02:50 swi-mdm9x28 user.crit Legato: CRT | audioDaemon[796]/framework T=main | LE_FILENAME TermSignalHandler() 643 | Terminated
Jan 6 00:04:44 swi-mdm9x28 user.crit Legato: CRT | watchdog[669]/watchdogDaemon T=main | watchdog.c WatchdogHandleExpiry() 488 | Mandatory watchdog double fault on process [audioService][audioDaemon]
Jan 6 00:04:44 swi-mdm9x28 user.emerg Legato: EMR | watchdog[669]/le_pa_wdog T=main | pa_wdog.c pa_wdog_Shutdown() 72 | Watchdog expired. Restart device.