mangOH red can't get correct time when it connects to network


#1

Hi guys,

I have one mangOH red with WP7607 and use twilio sim to connect LTE network.

When mangOH red connects to network successfully, I wait some time and use “date” command to query system time.

It shows “Sun Jan 6 00:04:05 UTC 1980”.

It seems that mangOH red can’t get correct time via ntpd.

I search related discussion and find this article
(https://forum.legato.io/t/how-to-change-ntp-server/3124) .

It mentions that we can change NTC server or disable time daemon by editing /etc/time_service.conf .

And the system time I get looks like GPS time.

My question is that how to complete time synchronization when device connects to network.

Such as modifying time_service.conf or use ntpd.

Thanks!


#2

< Update ! >

When I use mangOH red + sierra sim, this phenomenon will not happen.

mangOH red can get correct network time.

Can someone help to answer it?

Thanks!