MangOH Green: GPIO doesn't work

I have a mangOH Green with a wp7607 module. I have a serious problem with communicating via SPI: it seems not to work.

I installed the basic version of the system:

I compiled the mangOH layer and the green.sdef file is here:

SPI is not present in the drivers installed on the board. I obtain the following problem in the logfile:

I tried also the way of download yocto and compile and modify the quic-menuconfig, but I obtain the same result: SPI doen’t work, since I’m trying to use a CAN device that needs SPI and I see “cannot find device can0”.

I also tested on the oscilloscope: when I give the command mux 4 (or mux 5) I see high only the Slave Select and so the SPI clock, MISO and MOSI are zero and nothing happens. What sould I do in order to solve this problem? Have I to modify the file green.sdef or other files, since nothing changes if I use yocto config?
Ironically, if I wanted to drive the gpio SPI 51 at a low value, what could I do?

no one can help me?? please :disappointed_relieved: