Linux distro source won't untar?

Hello,

Every time I have tried downloading the linux distro source tarball from here, I cannot successfully decompress it. I have tried tar, bunzip2, and 7-zip. When I run “tar –xjvf archivename.tar.bz2” it complains about some end of file error. Am I doing something wrong or is the archive on the website corrupt? And why is it 8GB when the past versions have been ~3GB?

I just tried it and got the same result. The file seems to be damaged somehow.

The file size should be 8820598133 and sha1sum should be cf96bbc5fe4749ee938902b236782625456e7c80.

The change in size from the tarball mainly comes from downloaded content in yocto/downloads-build/
That format for shipping our code is on it’s way out. We’ll continue producing these massive tarballs but we’ve preferred to invest in ways to ship things as git.

The release 13.1 is available through leaf ( https://docs.legato.io/latest/toolsLeaf.html ) and the code can be downloaded from http://gerrit.legato.io . See https://docs.legato.io/latest/toolsLeafGetsrc.html and https://docs.legato.io/latest/confLeafSrc.html

You can also use repo directly.
Once you’ve registered to gerrit.legato.io , set your username and set-up your SSH key, the following commands should allow you to download the code:

repo init -u ssh://$GERRIT_USER@gerrit.legato.io:29418/manifest -m products/wp76xx/releases/Release13.1.xml -g default,-cache
repo sync

EDIT: Forgot -g default,-cache which prevents downloading the downloads/ repository from Gerrit (slow)

seems same issue as this one:

maybe you can try on Ubuntu 14.

1 Like

Hi there ,
As per your suggestion i tried downgrading bzip2 to 1.0.6-8.1 and libbz2 to 1.0.6-8.1 in my Ubuntu 16.04.6 LTS (Xenial Xerus) system but unfortunately with the downgraded bzip2 i have below error popping-up

bzip2: Data integrity error when decompressing.
** Input file = (stdin), output file = (stdout)**

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover’ program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
I am also attaching logs for the same , Please have a look and let me know how to overcome this issue or let me know if i am missing something .

bzip_version

Thanks & Regards

  • Akshay

how about using Ubuntu 14.04?

Also, can you make sure that the sha1matches the one that I provided ?
sha1sum <file> should return:

cf96bbc5fe4749ee938902b236782625456e7c80

That solved it for me, thanks so much. Not sure how I missed that post, that’s definitely my bad. I just downgraded to the version specified in the sierra forum post.

We use lbzip2 to compress, and it looks like there might be some compatibility issue.

You can also use it to decompress, which should be faster since it can use multiple thread (while bzip2 is single-threaded).

It can be installed with:

sudo apt-get install lbzip2

Still investigating here, but if you’re facing the issue, the following command seems to work better:

tar -I lbzip2 -xf Legato-Dist-Source-mdm9x28-SWI9X07Y_02.28.03.03.tar.bz2

I just tried it with lbunzip2 and it worked.

An update to bzip2 showed up in the Update Manager today, and the changelog contains this:

"bzip2 (1.0.6-8.1ubuntu0.2) bionic-security; urgency=medium

  • SECURITY REGRESSION: bzip2 update for CVE-2019-12900 causes some files raises
    incorrect CRC error. (LP: #1834494)
    • debian/patches/Accept-as-many-selectors-as-selectors*.patch

– Leonidas S. Barbosa leo.barbosa@canonical.com Thu, 04 Jul 2019 09:35:36 -0300"

So, after this update is installed, the problem should go away and tar xjf and bunzip2 should start working with this download again.