Libusb partly working on red - cannot find usbfs


#1

Hi
I am working with a mangoh red board with a wp7502
I am having problems with libusb, that seems to be partly working,
If I call lsusb it will break with an "exception unable to initialize libusb: -99" but libusb -t seems to work

I have tried the fixes i USB driver failing to find or power USBs with no luck.

When I try to call libusb from python it seqfaults and if i try from mono i am able to get libusbversion but as soon as try to get the device list it seqfaults.

I also have tried to make a new images with newer versions of libusb. but with no luck yet.

Has anyone else had success with libusb?

[updated]
If i set debug level for libusb to 4 it shows the following message:
[ 0.000030] [00001b43] libusb: debug [libusb_init] created default context
[ 0.001678] [00001b43] libusb: debug [libusb_init] libusb v1.0.21.11156
[ 0.004731] [00001b43] libusb: error [op_init] could not find usbfs
unable to initialize libusb: -99

So the real question now is what to add to make the usbfs available.


#2

Solved:

Adding symlink from /sys/bus to /dev/bus fixes the problem:
ln -s /sys/bus /dev/bus