Legato not working


#1

Hello guys,

     legato stoped in my mangoH Red board flashing new yocto image.

     I've downloaded "Legato-Dist-Source-mdm9x06-SWI9X06Y_02.13.02.00.tar.bz2" and builded  yocto for wp77XX without any configurations.
   Legato is not starting by default,. Hence i started running legato manually and encountered below errors.

  _**root@swi-mdm9x28:~# legato start**_

Starting Legato…
./system/bin/startSystem: error while loading shared libraries: libssl.so.1.0.2: cannot open shared object file: No such file or directory

  Is there any thing, that i've to configure in default yocto for legato..?

Thanks & Regards,
Mallikarjuna Reddy


#2

Did you build/install Legato separately from yocto?

It looks like you’re not using the latest yocto release for your module. That can be found here: https://source.sierrawireless.com/resources/airprime/software/wp77xx/wp77xx-firmware-latest-release-components/ and is SWI9X06Y_02.18.05.00.


#3

Hi dfrey,

  Thanks for you support.
  I din't build legato separately. It should be part of yacto right..?
  I've used "SWI9X06Y_02.13.02.00"  Release 7.

Thanks & Regards,
Mallikarjuna Reddy


#4

Is there a reason why you don’t want to use release 9.1 which I linked to in my previous post?


#5

Hi dfrey,

 I've download release 9.1 and facing some build issues, when i apply Bluetooth patches.

Please find below build log file FYR.

yocto-build.log (22.4 KB)

Thanks & Regards,
Mallikarjuna Reddy


#6

Hi @mallikarjunareddy,

The legato team has recently started publishing a lot of their repositories through a public gerrit instance. This gerrit instance is available at https://gerrit.legato.io. You need to have an AirVantage account to login.

Once you’re logged in, you need to go into the settings and upload an ssh key. You also need to choose a username in the settings.

Now you should be able to do:
git clone ssh://gerrit.legato.io:29418/meta-swi.git meta-swi

The other relevant repository is msm-3.18 which is the linux kernel repository for the wp76/77. Please see my recent commits to both of those repositories that relate to bluetooth. Specifically commit ad1c0353657b945c0f6a1e5617b7011f1f8b628e to the kernel resolves the error in your yocto log.