LAN9730 over HSIC on WP7607


#1

Hello all,

I am trying to make LAN9730 working thru HSIC interface.
I have made my own board. Both lines have same length of 55mm.

I installed the toolchain and compiled the driver.
I load the driver on the WP7607:
insmod smscusbnet.ko
insmod smsc9500.ko

The modules are successfully loaded.
But I see no Ethernet interface appearing.

With dmesg I see:

[ 2191.965712] usb usb1-port1: unable to enumerate USB device
[ 2192.090192] usb 1-1: new high-speed USB device number 70 using msm_hsic_host
[ 2192.220184] usb 1-1: device descriptor read/64, error -71
[ 2192.460173] usb 1-1: device descriptor read/64, error -71
[ 2192.690243] usb 1-1: new high-speed USB device number 71 using msm_hsic_host
[ 2192.820188] usb 1-1: device descriptor read/64, error -71
[ 2193.060367] usb 1-1: device descriptor read/64, error -71
[ 2193.290185] usb 1-1: new high-speed USB device number 72 using msm_hsic_host
[ 2193.710195] usb 1-1: device not accepting address 72, error -71
[ 2193.830194] usb 1-1: new high-speed USB device number 73 using msm_hsic_host
[ 2194.250141] usb 1-1: device not accepting address 73, error -71
[ 2194.255151] usb usb1-port1: unable to enumerate USB device
[ 2194.380192] usb 1-1: new high-speed USB device number 74 using msm_hsic_host
[ 2194.510214] usb 1-1: device descriptor read/64, error -71
[ 2194.750201] usb 1-1: device descriptor read/64, error -71
[ 2194.981152] usb 1-1: new high-speed USB device number 75 using msm_hsic_host
[ 2195.151046] usb 1-1: device descriptor read/64, error -71
[ 2195.431033] usb 1-1: device descriptor read/64, error -71
[ 2195.661057] usb 1-1: new high-speed USB device number 76 using msm_hsic_host

Any idea to make it works?
Did I miss something?

Thank you for your support,

CS


#2

Hello,
did you solve this problem? Got the same problem with a custom board hsic->usbhub


#3

Hello,

No I did not solve it yet.
If I find a solution I will share it here. It would be great if you can do so :slight_smile:


#4

I changed the oscillator, now its working fine