Install application from airvantage


As you can see you are missing the following in communication

             <parameter name="version" value="core=1_0-20151214,sw=1_0-20151201"/>

Adding the above line to the application model under communication / protocol will fix the problem you are seeing. As already mentioned in this ticket, the official version is 16.10. So the released application model is referring to the old lwm2m version.

If you want to use newer versions, please update your application model manually and attach your device to the new firmware application model.


Hey guys,

Just want to get some clarification from this thread - have you guys been able to do a remote update on an application with Legato 17.xx?

We are just starting to look into doing the remote updates now and are hoping to learn from anyone else’s mistakes.




@nilsarve can you let us know if this fixed your problem.
@coastalbrandon, for 17.xx please use the right protocol version.

Our team is doing fota/sota on a daily basis and the big learning here is probably to make a video tutorial on this topic.

@Mirac lets make a video tutorial on this topic next.


A video tutorial would be great!


No problem, let’s discuss the topic when we meet :slight_smile:


Got it working with legato 17.11 now!

  1. Downloaded the current “firmware” file unzipped and added the <parameter name="version" value="core=1_0-20151214,sw=1_0-20151201"/> line to Edited the name and revision.
  2. Zipped and uploaded to my apps. Published.
  3. Edited my device and added my new application.
  4. Rebooted my device with legato 17.11 and avcControl (with auto start)
  5. Installed my own app from airvantage. :+1:


Hey @nilsarve,

I followed the steps you listed as closely as possible but I keep getting a Binary packages missing error from AirVantage when trying to upload my modified “firmware” package.


The zip I downloaded was called and contained the, oma.cp and swir.cp.


Thank very Much work fine with my wp8548 and legato 17.11.


Hi Nilsarve,
I have couple questions related to your described steps:

  1. As you wrote Edit Name and Revision. Does it mean edit directly in file?
    example: name=“WP8548_SWI9X16Y_07.12.09.11” revision=“SWI9X16Y_07.12.09.11”>
  2. As you wrote Zipped. Do you mean zip together with original oma.cp and swir.cp files?
  3. As you wrote Added my New Application. How ? Do you mean New Firmware?
    What about Binary File? I have “Binary packages missing error”.

Thanks a lot for more explanation!



Just download the original application (zip file)
Rezip with the other file
Upload to airvantage as a new application
attach this new application to the system and remove the old
Don’t forget to build and install avcControl (without OTA doesn’t work) In your mangoh.

I have deployed 4 mangoh this week. All work fine


Hi Francis,
So you probably do not see “Install not supported” Error message



I not have this message.
To add the application I edit the system and in the field Application I click to the + button.

Send me a email . I will send the zip file and a detailed Tuto with screen copy. I m out of office It will be possible next Tuesday

My email


Thanks a lot this worked for me too.


Hey team,
I’ve been seeing “Binaries Missing” when I try to update the modified firmware zip file. The steps i’m taking:

  1. download old firmware file.
  2. update file with the snippet from above.
  3. re-zip the entire folder with, oma.cp and swir.cp.
  4. upload the new firmware zip file and try to push it to my MangOH. This is when I see the error.

I have made an app that i’m hoping to push to my mangoh over the air, but i suspect I won’t be successful until I have the above sorted out.

Note: i also just tried updating to the latest wp8548 firmware that was released 3 days ago over the air and i got the “Binaries Missing” error as well.



You just to attach the application to your system.
Go to air vantage
Push your new application
Edit your system
Click to + to add the new firmware
You cam remove the old
Click to Save button