How to debug linux boot process



I’m experimenting with different yocto built images.
Sometimes Linux not booting, and I want to know why.

How can I examine boot messages?
I tried to connect to DB9 connector, with different baud settings, no output was visible.



You should connect to the DB9 connector with 115200 8N1.


Thank you for your reply dfrey,

Unfortunately still nothing is visible on the terminal.

Here are some facts:

  • RS232 cable was checked, and working properly.
  • Linux flashed on WP85 is working. I can ssh into.
  • I’m able to flash the device using swiflash utility.
  • I’m able to flash the device using fastboot. But for some reason, Linux is not starting this way.



Please try to download latest firmware here:

It’s a simple one click tool.
Let’s see if that makes any difference


Thank for your reply asyal,

I downloaded newest generic-firmware, boot-yocto, legato and MCU packages.
Flashed using swiflash. Utility reported success for all operations.

Unfortunately that did not help. Still no output on DB9.

I’m suspecting hardware problem.


Yes, could be.
Can you ssh via USB?


Yes, I can ssh.
I’m working on Ubuntu 16.04.
After connecting Mango0h to USB port, new ethernet device is visible and working.


you may try to change the uart as Linux console using AT command. It may work.
Here is the steps:

ssh to device

microcom -E /dev/ttyAT

AT!MAPUART=16,2 (uart 2 as Linux Console )
AT!MAPUART=16,1 (uart 1 as Linux Console )

then restart



Thank you all for your help.
Finally, I solved my problem.

First, I replaced WP8548 chip. I’ve got a new one, which works. Finally I saw some data produced by serial port.

Second, my cheap RS232/USB converter fails on 115200 baud. All I saw on terminal was white spaces.
Decent converter based on FTDI chip works much better.



Thx for letting us know


my cheap RS232/USB converter fails on 115200 baud

If you know the make and model or chipset of the non-working RS232 adapter, then please post it to help others diagnose this problem in the future.


I’ve tried two “cheap” converters.

The black one, recognized by system as:
Bus 001 Device 010: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

Sometimes received data are corrupted (random characters). Converter is unable to send valid data.

The blue one, recognized by system as:
Bus 001 Device 009: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

This one is unusable. Receives random sequence of spaces, tabs, and line feed characters.

Both converters works fine using 9600 baud.


I have two that look like your second one. One wont work at all and teh other comes up as a prolific. Unfortunately the Windows driver has frozen it out presumably because it is not a genuine chip inside. Using an older version of the driver works fine though.



I am using the blue one (PL2303-Prolific) as well and from what I found from the net, there is issue with driver. I am not able to make it work on windows. However it works well on Ubuntu 16.04, here are the instructions:

  1. connect the serial adaptor to usb port of the Ubuntu machine.
  2. install minicom in linux machine:

sudo apt-get install minicom

  1. find the usb port that serial connect to:

dmesg | grep pl2303

  1. the output of step3 would indicate which usb port

[ 6.804403] usb 1-1.3: pl2303 converter now attached to ttyUSB0

  1. change file permission to allow minicom to save config using ttyUSB0 as an example

sudo chmod 755 /dev/ttyUSB0 minicom
mnicom -s

  1. from the config menu, select “Serial port setup”.
  2. press “A”; update A-Serial Device: to what you see in step4. It would look like
    A-Serial Device: /dev/ttyUSB0
  3. hit “enter” and then press “E” to select “E-bps/par/Bits: 115200 8N1”
  4. hit “enter” and select “save setup as dfl” and select “Exit”

If everything goes well, you will see
"Welcome to minicom 2.7
Port /dev/ttyUSB1"

type your user name and password to login to your mangOH board.

WP8548 stuck in init process

For the UART converters, most of the cheap one are very unreliable and will waste your time (fake Prolific chips, …)

I’ve been using the Trendnet TU-S9 for about 10 years and never had any issue with them, cf . They cost about 15 bucks, so about 3 times the price of something that works a third of the time … :stuck_out_tongue: