How to configuration to using PCM in IOT#0?


#1

I can not see any documents talking about this? Can you help me? Thanks


#2

Hi,
Are you asking how to direct PCM to IoT#0 and not to audio codec?
If so, you can do that using the mux control tool.
Please follow the instructions on how to download from github.com/mangoh.
Let me know if you run into issues.
regards,
Ashish


#3

Thank for your help
Yes, I want to using to derect PCM but now I don’t have seirra wp, I’m using the HL8548. Can I config or change the hardware board to do that?
I tried connect the CN601 but the logic voltage is too low (about 200mv).


#4

you should be able to use CN602, it is a direct connection.Are you sending any AT command to activate your HL module for PCM? Usually PCM lines will be low unless you activate them.


#5

Thank Asyal for quick supported


I thing the PCM directing connection is CN601. I tested the PCM by answer an calling. The clock, data, ck sync is seam ok . But I was measured the logic voltage by oscilloscope is very low (~200mv). What the other way disable the codec ic ?

I read document: Can I config the Mux1 via hardware?


#6

You need to disable U910. So resistor R910 should be removed and try to pull PCM_EXP1_ENn to high (1.8V should be enough)


#7