How to build MCP2515 CANBus drivers for mangOH

I downloaded at the link: https://source.sierrawireless.com/resources/airprime/software/wp76xx/wp76xx-firmware-release-13-components/#sthash.TvXunzr3.dpbs

then can you make the yocto image by just type “make” in yocto folder?

FYI, here I don’t see problem to “make image_bin” with FW R13.

For the same problem, with module WP76, I use Release 16 + Legato 19.11.2. What does it change?

what do you mean?
Do you see any problem with that?

![image|690x173]

I see this error…

here says ubuntu18 has problem on automake, are you using ubuntu18?

FYI, i am using ubuntu 16 and Ubuntu14 to build.

I downloaded the VM from mangOH website from the getting started options, so I’m using Ubuntu 18.04. Then I installed Leaf and Legato on Visual Studio. So how can I use this module?

I solved the problem after deleting my yocto folder. After having downloaded it again, I repeated the guide procedure and everything went ok. I just have to wait

image

maybe you delete the yocto folder and download again.

Which FW release should I download?

R13

https://source.sierrawireless.com/resources/airprime/software/wp76xx/wp76xx-firmware-release-13-components/#sthash.TvXunzr3.dpbs

Hi,
I just downloaded R13 and I arrived at the sixth step of the procedure explained in the following link:
https://github.com/mangOH/mangOH/wiki/How-to-build-MCP2515-CAN-driver-for-mangOH-Green-slot-1,-9x15-based-systems.

But I obtained a different situation regarding the folders, unlike what was declared in the guide below:

.

In particular, when I go in yocto/build/build_bin/tmp/work/swi_mdm9x28_wp-poky-linux-gnueabi I find the folder “linux-quic” and not “linux”:

Then, opening my version 3.18.131-r1 I don’t find “linux” but “kernel”:

.

Moreover, opening the path that you can see in the following pic, I don’t find the file “board 9615.c” as mentioned in the guide, but the files 9607.c, 9640.c and 9650.c:

Finally I obtain the following situation on the terminal:

What could be the cause of these differences between the results obtained and the guide?

PS. I also tried to modify the code, using the files 9607.c, 9640.c and 9650.c, but it doesn’t work.

the link you referring to is for WP8548/WP75, that is why it is talking about board 9615.c
For WP76/WP77, you can use 9607.c.
Probably you need to see if the patch can be applied to 9607.c

Sorry, how could I know if a patch can be applied to 9607.c?

You can open the patch and see if you can add those modified line to your .c file

I remember even i did not add the patch, i can still see the CAN driver on mangoh red board

Could a cause of this problem be the fact that in the linux-yocto configuration I don’t see the microchip
image
(as reported in the gitHub guide)?

Do you see problem if not modifying the yocto , but just add the mangoh layer to have the CAN driver?

I didn’t modify anything, I just followed this guide:
https://github.com/mangOH/mangOH/wiki/How-to-build-MCP2515-CAN-driver-for-mangOH-Green-slot-1,-9x15-based-systems.

You can see my testing here:

Do you know if there is a guide to acquire a CAN signal with the following tools:

  • mangOH green
  • WP7607
  • Talon CAN Bus IoT extender for Sierra mangOH IoT
    ?

I’m so confused :woozy_face: