How can I create mmc interface in R16 ? (Or there is a better way to deploy wifi module of mangOH-yellow )

We can use the wifi function successfully on Mangoh Yellow (with fw: mangOH-yellow-wp76xx_0.7.0.spk)
we use instruction:
wifi client start
then we can create a wifi devide node on system.

but we found some problem after used the Yocto re-build kernel image of R16 and updated it
the “wifi client start” became unavailable

My guess is that the wifi driver is not deployed in the R16 kernel
Therefore, I copy the wifi driver in mangOH-yellow-wp76xx_0.7.0.spk to the current system, and plan to use the insert module to build the wifi device node

But I can’t find mmc interfcae even I’m insert sdhci-msm.ko.

how can I create mmc interface in R16 ? (Or there is a better way to deploy wifi module of mangOH-yellow )

does this help?

1 Like

it is working for me!
you are the lighthouse in the miserable!!!

I found the ecm cannot connect to pc after I update fw tha build with R16(adding the meta-mangoh layer & add a new directory under the root directory).

Even if I manually set the ip of mangoh( & PC(, it still unable to connect to each other.

I try to test on other boards , if I upgrade from mangOH-yellow-wp76xx_0.7.0 to this version of FW(I test ), ecm functions ais work.

But if I upgrade from the previously FW (built by myself , add a directory under the root directory) to the current FW (add the meta-mangoh layer), ecm will not be able to connect after the update.
I tried to re-flash to mangOH-yellow-wp76xx_0.7.0 , the ecm can be connected after the re-flash .
But if I update to the FW that I built by myself , the ecm cannot work again.

Are there any good suggestions to make the ecm function work on the new FW that I built? I’m worried that the same problem will happen again after updating FW

you might need to shut down firewall by
iptables -I INPUT -j ACCEPT

1 Like


Thanks again !

I can successfully clone meta-mangoh.git in the R16 and compile successfully.

but I got error when I tried to add meta-mangoh.git in the R13(Legato-Dist-Source-mdm9x28-SWI9X07Y_02.28.03.01.tar.bz2 ) and recompile(Compilation was successful before adding meta-mangoh)

May I ask what is the reason for this? How to fix it?

You need to use r16 then

To get the dev configs loaded to connect for your own FW, you need to apply the one commit from this branch on meta mangoh: GitHub - mangOH/meta-mangoh at mdev_update_for_ecm

1 Like

Hi jameswollaeger,
Thanks for your information.
I’ve tried to clone this branch to R13.3 yocto folder and make again , but it still get some error as below:

Does it need some patch or code change?

I’m using the R16 Yocto release, I’ve never tried the R13.3. I can say I’ve never seen that error before.

1 Like