HL module connecting to cellular network


I am using an HL7748 on my mangOH red board. I had been using the WP8548, which worked well. I am trying to send SMS commands to the HL, but it seems it is not connected to the cellular network. Everything worked fine with the WP, so I swapped out for the HL, keeping everything the same. On the WP, when I send an at+cops? command I get a +COPS:0,0,“AT&T Sierra Wireless”,2. With the at+cereg? I get +CEREG:0,4. ON the HL, I get +COPS:0, and +CEREG:0,3. I tried to manually register it with at+cops command using the name of the network I got using the WP chip. Also tried the at+cgatt command (to try to attach it) and tried to follow the steps I found online on how to register and attach a device. When I issue an at+csq, (signal quality), I get a +csq:99,99. Is anyone here using the HL on the mangOH red for cellular data, and if so, how did you get it to register to a network and work? Seems there needs to be some configuration done on my chip and I think it is something simple that is not enabled.

I guess the application processor on the WP is doing some initializing that is not being done on the HL?

Also, is there any documentation out there from Sierra Wireless on how to manually register the chips to a network? Or steps on how to send it AT commands for different configurations??


I put HL7528 to mangoH Red board, it can register network and send SMS to my mobile.
I don’t type anything special…


Must be nice :slight_smile: Are you using the Sierra SIM card that was included with the mangOH Red board? That 7528 looks to be tri band LTE also, though uses different bands than the 7748.


I used a normal SIM card.



The HL7748 is a Cat M1 only device, for the unit to be able to attach to this network you need to have a specific SIM from AT&T which is capable of attaching to it, it will not work with any old SIM and almost certainly not with a roaming one.

You have sort of said so above but can you confirm the networks you see with the below command (which will take a minute or two to complete).

Assuming you can see the network it will be a SIM card issue, you will also need to make sure you have the AN setup correctly for the M1 network is CID (at+cgdcont) 1.




Hi Matt!! You are everywhere in these forums :). I actually popped in my personal SIM card which is ATT. I am now at least getting decent signal quality. Before , it was unknown. Responses I am gettin are +cops:0, OK (no network name is shown ). Originally my +cgdcont was “IPV4V6”,“broadband”,0,0,0,0,0. I then changed this to internet.sierrawireless.com but still nothing really changed. Maybe I need to use an ATT APN? Also getting +cereg 0,3 and +creg: 2,3. Should I be able to send SMS without the APN being correct ? I also tried to manually and auto register my device with at+cops command using a multitude of combinations. I can pop in my WP chip and all is good. +cops shows up as ATT, I can SMS and transfer data to air vantage. I think it is something “simple” that isn’t correct with the HL7748 settings. I was supposed to have a call with my Sierra distributor last Friday , but have not heard from him yet. He has also been sending me things to try. It’s never easy …


I didn’t read this carefully enough. About the cat M1 capable SIM card. Perhaps my SIM card I use in my ATT phone is not compatible. I will look at this in the morning.


I think you were correct. And I am surprised my Sierra distributor did not bring this up at the beginning. I am trying to find a CAT M1 sim card now. If I buy a data plan from ATT, it will take up to 2 weeks to get my SIM card in the mail. I have asked my Sierra Dist. if they happen to have one they could send me also.


So I am waiting for my Cat M1 sim card to come in. In the meantime I have popped in my WP8548 and just brought up tera term to send commands to it for testing. Everything seems to be initialized. I am trying to start a TCP connection but all I get is an error.

BIG EDIT: So I just erased most of my post, because I came across a reply of yours on the main Sierra Wireless forum. Looks like I can’t send data over TCP with AT Commands on the WP 8548? Is this correct?



For the WP8 no you can send AT command over the UART or the USB, or you can start a data session from within the kernel.

Key point is, if you have a Sierra SIM use a Sierra APN, if using an AT&T SIM use an AT&T APN.

Probably the simplest way itis to do it from within the kernel using the cm (connection manager) tool. Help for it is here


The basic sequence will be

cm apn <APN NAME>
cm data auth <none/pap/chap> <username> <password>     //This is optional depending on whether the APN needs a username and password or not.
cm data connect&     //The & is important otherwise it will not go back to the terminal once the connection is in place and you will need to start a new SSH session.




Hi Matt,
Thanks for the reply. That is actually what I did for the WP : I setup everthing via ssh using the cm commands. I had my ATT card in there and was able to send sensor data to airvantage as a test. What I want to do is send AT commands to it (over usb with Tera term or with my uC) to send TCP packets to a web server. (So I can do some testing while I wait for my Cat M1 SIM card for the HL). Company’s project is going to use the HL, but I have both chips. I have the HL AT command ref which has the commands to setup a TCP connection. These don’t seem to work on WP8548. I also tried some other commands I found online. I am sending this on mobile , but when I get on my computer I will reference the post of yours about this topic that I saw to make me think it wasn’t supported. (Unless it had been changed with a firmware update ).


I finally found the old post on this…here it is…

This was talking about FTP, but they also asked about TCP (which I think FTP goes over TCP protocol). I think my sim card will be here in a day or two, but I was going to try to send AT commands to the WP8548 to establish a TCP connection, but I don’t think I can do this? My external microcontroller is going to control everything, just using the WP as a cellular chip. Or should I just wait for my sim card to get here and use the HL? ( In hindsight, my company probably should have just used the WP from the start for the prototype. )



Correct, you cannot use AT commands to set up a socket connection and then just stream data to the serial port, you either need to use Legato or an IP stack on your micro.




I got my sim card today. Started to work on it. Looks like it connects to the APN and registers with the network. (when I send at+creg? and at+cops? commands). I am trying to send SMS messages. I send this “AT+CMGF=1\r”; (for SMS mode). Then I send “AT+CSMP=17,169,0,0\r”; I get OK as responses to these. Then I send a “AT+CMGS=“1+xxxxxxxxxxx”\r” (where the x is my phone number). In response I get a “>” character. I then send my message along with the ctrl-z character and after I send the message I get +CMGS:33 (or whatever the number may be. It increases as I try to send each message). So it seems like everything worked, but I am not seeing come through on my phone, and when I log into my SIM card provider, I still have 0 SMS messages sent. I am using the same AT commands for SMS that I did for the WP chip, which worked fine. It is late here and I will continue to look at this tomorrow, but we are so behind on this I wasn’t sure if there was something obvious that I was missing. I thought it could be my phone number. I tried without the +, without the country code, etc but still same behavior. I do see that there are some examples in the AT command guide for TCP connections, so hopefully that will be able to help me with that part.

Edit: I am able to receive SMS with my Neo SIM card website, and if I get another SIM card, it should work. NEO does not allow SMS to a non NEO SIM card device. BUT, I am still having no luck trying to get TCP connection. Every TCP AT command I send to the device gives me an error