HL module connecting to cellular network


#1

I am using an HL7748 on my mangOH red board. I had been using the WP8548, which worked well. I am trying to send SMS commands to the HL, but it seems it is not connected to the cellular network. Everything worked fine with the WP, so I swapped out for the HL, keeping everything the same. On the WP, when I send an at+cops? command I get a +COPS:0,0,“AT&T Sierra Wireless”,2. With the at+cereg? I get +CEREG:0,4. ON the HL, I get +COPS:0, and +CEREG:0,3. I tried to manually register it with at+cops command using the name of the network I got using the WP chip. Also tried the at+cgatt command (to try to attach it) and tried to follow the steps I found online on how to register and attach a device. When I issue an at+csq, (signal quality), I get a +csq:99,99. Is anyone here using the HL on the mangOH red for cellular data, and if so, how did you get it to register to a network and work? Seems there needs to be some configuration done on my chip and I think it is something simple that is not enabled.

I guess the application processor on the WP is doing some initializing that is not being done on the HL?

Also, is there any documentation out there from Sierra Wireless on how to manually register the chips to a network? Or steps on how to send it AT commands for different configurations??


#2

I put HL7528 to mangoH Red board, it can register network and send SMS to my mobile.
I don’t type anything special…


#3

Must be nice :slight_smile: Are you using the Sierra SIM card that was included with the mangOH Red board? That 7528 looks to be tri band LTE also, though uses different bands than the 7748.


#4

Hi,
I used a normal SIM card.


#5

Hi,

The HL7748 is a Cat M1 only device, for the unit to be able to attach to this network you need to have a specific SIM from AT&T which is capable of attaching to it, it will not work with any old SIM and almost certainly not with a roaming one.

You have sort of said so above but can you confirm the networks you see with the below command (which will take a minute or two to complete).
at+cops=?

Assuming you can see the network it will be a SIM card issue, you will also need to make sure you have the AN setup correctly for the M1 network is CID (at+cgdcont) 1.

Regards

Matt


#6

Hi Matt!! You are everywhere in these forums :). I actually popped in my personal SIM card which is ATT. I am now at least getting decent signal quality. Before , it was unknown. Responses I am gettin are +cops:0, OK (no network name is shown ). Originally my +cgdcont was “IPV4V6”,“broadband”,0,0,0,0,0. I then changed this to internet.sierrawireless.com but still nothing really changed. Maybe I need to use an ATT APN? Also getting +cereg 0,3 and +creg: 2,3. Should I be able to send SMS without the APN being correct ? I also tried to manually and auto register my device with at+cops command using a multitude of combinations. I can pop in my WP chip and all is good. +cops shows up as ATT, I can SMS and transfer data to air vantage. I think it is something “simple” that isn’t correct with the HL7748 settings. I was supposed to have a call with my Sierra distributor last Friday , but have not heard from him yet. He has also been sending me things to try. It’s never easy …


#7

I didn’t read this carefully enough. About the cat M1 capable SIM card. Perhaps my SIM card I use in my ATT phone is not compatible. I will look at this in the morning.


#8

I think you were correct. And I am surprised my Sierra distributor did not bring this up at the beginning. I am trying to find a CAT M1 sim card now. If I buy a data plan from ATT, it will take up to 2 weeks to get my SIM card in the mail. I have asked my Sierra Dist. if they happen to have one they could send me also.


#9

So I am waiting for my Cat M1 sim card to come in. In the meantime I have popped in my WP8548 and just brought up tera term to send commands to it for testing. Everything seems to be initialized. I am trying to start a TCP connection but all I get is an error.

BIG EDIT: So I just erased most of my post, because I came across a reply of yours on the main Sierra Wireless forum. Looks like I can’t send data over TCP with AT Commands on the WP 8548? Is this correct?


#10

Alex,

For the WP8 no you can send AT command over the UART or the USB, or you can start a data session from within the kernel.

Key point is, if you have a Sierra SIM use a Sierra APN, if using an AT&T SIM use an AT&T APN.

Probably the simplest way itis to do it from within the kernel using the cm (connection manager) tool. Help for it is here

https://docs.legato.io/latest/toolsTarget_cm.html#toolsTarget_cm_data

The basic sequence will be

cm apn <APN NAME>
cm data auth <none/pap/chap> <username> <password>     //This is optional depending on whether the APN needs a username and password or not.
cm data connect&     //The & is important otherwise it will not go back to the terminal once the connection is in place and you will need to start a new SSH session.

Regards

Matt