Help needed for Arduino -Mangoh communication

Hi Team,

Good Evening. I am Sravan and working for movimentogroup who works closely with sierra wireless. I have one mangoh green board with me and trying the following .
  1. Connect Arduino leonardo present in mangoh to CF3 module
  2. Write a basic program like blinking LED
  3. DUmp this code into Arduino using Primary module (not with mini USB cable) and execute it in the Leonardo board.

I am facing the difficulty in accessing the arduino board from CF3 module and heard that there should be some bridge application to do that. Can you please explain me the step by step procedure to do that.
Thanks in Advance. I have been trying this from ages.

Hi Sravan,

We will be releasing the code for Arduino as well as mangOH related applications (IoT modules, GPIO expander etc.) on the mangOH Github site. This should be available shortly in a few days.


Ok…thank you Ashish…I am not able to access Arduino board even from mini USB cable also :frowning: it is not detecting in my ubuntu serial connecting devices.

Hi Sravan,

As discussed, you were using a DV2 board that was early hardware. Please switch to DV4 hardware that has been configured for Arduino usage and the Arduino not being detected problem should go away.
Also, note that at the present moment you will need to download code to Arduino using the usb mini cable.
We provide the bridge connection between WP and Arduino to operate once the code in Arduino has been downloaded.

Please note that we are investigating the ability to download code through WP to ATmega. Fundamentally, we dont believe it is a problem and will be able to add this support. Timing TBC

Hi Ashish,

Thank you for the support. I ordered  latest version MangOH through element14 which is yet to be delivered. So as of now I can download the sketches only through mini usb cable and not with the WP module. I will give a try  after getting the board. Once again thank you

Hello everyone,
I also have some problems with communication between arduino and mangoh. I am able to connect and flash the atmega by USB and get some sensors information but I would like to get those information back to the mangOH without using AirVantage or any network.
I cannot find anymore the arduino tutorial draft on the website or the airvantage library and I think this use case wasn’t explained inside anyway.
As it is a very common problem i guess the answer is quite simple but I couldn’t find it yet.
Thank you for your help!

If you can wait till mid next week, will release all the working code and provide a quick start guide.
We will release a detailed tutorial early next month.

1 Like

Is there any user guide available about how to write arduino sketch in the MangOH arduino. I have tried connecting using mini usb but arduino leonardo not detecting in my pc. I am using Arduino SDK 1.6.8

On IDE, you should select board as Leonardo and make sure the port is selected properly.
Check tomorrow and we will provide working code for you there with some basic instruction.
We are working on arduino tutorial and will release draft version end of next week.

Thank you Ashis. But I don’t know why I cant able to see any Port no in my Arduino IDE. Nothing is detecting when I am connecting MangOH to my PC over MINI Usb cable. Also no LEDs are on. do i need to connect micro Usb cable to power up the board?


Make sure you are still providing power to the mangoh through power supply or micro USB cable

For code regarding Arduino please look at this post:

Thank you Ashish. Yes it is working.


I followed following documents for arduino -mangoh communication MangoH_Adruino_Tutorial_draft1.0.pdf.

I am able to compile and install on mangoH
[running] arduinoBridge
[running] dataRouter
[running] mqttClient

i am able to compile and upload the code to Adruino .

now i wanted to get the sensor data to mangoH , and i am stuck there .i Have tried with other example on github.mangoh i.e multisensor

but i am getting this error on device :
swi-mdm9x15 user.err Legato: =ERR= | arduinoBridge[24685]/bridgeComponent T=main | bridge.c mangoh_bridge_process_crc() 215 |
ERROR invalid crc(0xc6f3 != 0xffff)

Any detailed document available for arduino to mangoh communication .


Hi Khan,

We will release a preliminary but detailed tutorial document next week.



Attached is the tutorial doc. Would like to get your feedback on it and make any improvements based on it. Please use and make any recommendations for changes if you see any.


Hi Ashish,

I am following the instructions on the PDF linked above (Tutorial—Arduino-compatible Shield to AirVantage).
Everything works fine until step “f” in 3.1 (Install mangOH Green Platform Applications)
Step “f” is: Download (clone) the Project mangOH files
I run the suggested command and I get the following error:
acal@acal-Latitude-E6430:~/mangOH$ repo init -u “” -m mangOH.xml && repo sync

… A new repo command ( 1.23) is available.
… You should upgrade soon:

cp /home/acal/mangOH/.repo/repo/repo /usr/bin/repo

Get “”
ssh: Could not resolve hostname \342\200\234https: Name or service not known
fatal: I don’t handle protocol '“https’
fatal: I don’t handle protocol '“https’
fatal: cannot obtain manifest “”

thanks for your help


one problem is that the command in the PDF is wrong. In fact, the URL "”, which is part of step f, is wrong. It should be: "”, i.e. the last “s” in “manifests” is wrong.

Also, at the correct URL, the following instructions are given at the bottom of the page (point 4):
“Perform a clone of the relevant projects using repo repo init -u “” -m mangOH/mangOH.xml && repo sync”

This command is also different from the corresponding one on the PDF:
-m mangOH.xml && repo sync
-m mangOH/mangOH.xml && repo sync

I tried with these changes but the outcome is more or less the same:
acal@acal-Latitude-E6430:~/mangOH$ repo init -u “” -m mangOH/mangOH.xml && repo sync
Get “”
ssh: Could not resolve hostname \342\200\234https: Name or service not known
fatal: I don’t handle protocol '“https’
fatal: I don’t handle protocol '“https’
fatal: cannot obtain manifest “”


Hi Luigi,

You caught us in a transition to git submodules. Please see this new forum post for more details. Let me know if you are still having problems after reading that.