GNSS - no 3D fix with WP7702


#1

Hiya,

Not sure if this is a module, legato or mangOH issue - but I’m using the mangOH red so I thought I’d post here first.

I’m trying to get some GNSS positioning info out of the WP7702 - similar to what I’ve done in the past with the WP8548.

But what ever I do, I cannot get the GNSS engine to ever get a 3D fix. I’ve tried:

  1. 3 different antennas - including one that would get 3D fixes on a mangOH Red using the WP8548
  2. different locations - even out in the middle of a clear area with views to all horizons
  3. 2 different mangOH Red and WP7702 devices

Is there some command that needs to be sent to the WP7702 to enable/configure 3D fixes?

ciao, Dave


#2

what is the fw version on wp7702?


#3

Hi @asyal,

I flashed it up with the latest from ‘The Source’ (R9, I think), and then updated Legato to 18.05.1

info from device (less IMEI/FSN):

root@swi-mdm9x28:~# cm info
Device:                      WP7702
Firmware Version:            SWI9X06Y_02.16.04.00 019853 jenkins 2018/05/15 19:28:37
Bootloader Version:          SWI9X06Y_02.16.04.00 019853 jenkins 2018/05/15 19:28:37
MCU Version:                 002.009
PRI Part Number (PN):        9907365
PRI Revision:                001.004
Carrier PRI Name:            GENERIC
Carrier PRI Revision:        001.021_000
SKU:                         1103530
Last Reset Cause:            Power Down
Resets Count:                Expected: 9      Unexpected: 1
root@swi-mdm9x28:~# legato version
18.05.1_fa1d0f05b3362c0e6c1e3c60e9af01ed_modified
root@swi-mdm9x28:~#

ciao, Dave


#4

Do you get a 2D fix?


#5

Hi @asyal

Yep. But I haven’t drilled into the details to see what PDOP and HDOP are.

Also, I get a Direction (when the device is moving), but the Heading info is always invalid.

ciao, Dave


#6

Is your issue resolved?


#7

Hi @asyal

No. I spent all day with it in the card driving around yesterday and never got a 3D fix. I can probably get you the 1 seconds logs if you really want them :slight_smile:

Interestingly, I did some quick testing in the office using the gnss command (which I was previously unaware of) and it is reporting a 2D fix and an Altitude value that is pretty much correct for the office.

So now I’m confused. Is there an antenna issue, a mangOH or WP7702 hardware issue, or a Legato issue?

ciao, Dave


#8

If I summarize,you are getting an accurate reading for 2d on 77 and 3d on 85
To be clear, you are trying the use the legato API on 77?


#9

Hi @asyal

Yes. I have been able to get 3D fixes using the same hardware and the Legato API on the WP85, but I can’t repeat that using the WP77 (only get 2D fixes).

ciao, Dave


#10

Ok, so obviously not a mangoh issue. Do you have an error when the 3d command is issued? Or just no fix?


#11

Hi @asyal,

I have a periodic timer that first queries the fix state (NONE/2D/3D/UNKNOWN) and then depending on the result I then either get the 2D or 3D data.

I haven’t tried getting the 3D data if the fix state is being reported as 2D only … I’ll try that and see if the code explodes.

I’m not sure if it’s a legato issue or a WP77 issue.

ciao, Dave


#12

Hi @asyal

I’ve just changed to an external antenna hanging out the window of my office, and upgraded to Legato 18.08.0 in case there was an issue with 18.05.1.

gnss watch returns this:

TTFF(Time to First Fix) = 19039ms
Position state: 2D Fix
Latitude(positive->north) : -27.533114
Longitude(positive->east) : 153.025296
hAccuracy                 : 3.00m
Altitude  : 46.000m
vAccuracy : 3.0m
AltitudeOnWgs84  : 93.000m
GPS time, Week 2019:TimeOfWeek 100322000 ms
Time(HH:MM:SS:MS) 03:51:44:000
Epoch Time 1537156304000 ms
GPS time accuracy 33ns
UTC leap seconds in advance 18s
Date(YYYY-MM-DD) 2018-09-17
Position dilution of precision (PDOP) [0.0 0.8 0.80 0.800]
Horizontal dilution of precision (HDOP) [0.0 0.5 0.50 0.500]
Vertical dilution of precision (VDOP) [0.0 0.7 0.70 0.700]
Geometric dilution of precision (GDOP) invalid 65535
Time dilution of precision (TDOP) invalid 65535
hSpeed invalid [0, 4294967295]
vSpeed invalid [0, 2147483647]
Direction invalid [4294967295, 4294967295]
satsInView 44 - satsTracking 35 - satsUsed 27

still no 3D fix … but it is apparently using 27 of the 44 satellites in view…

ciao, Dave


#13

Hi @asyal,

I’ve just taken a mangOH Red board with a WP8548 in it and stepped through Legato versions from 16.10.3 onward. For each version I used the gnss fix command to wait for the gnss engine to obtain a fix, then used gnss posInfo to check the fix information. The tests were done over the space of about 30 minutes and the module and antenna were not moved during the tests.

Results:

Legato version TTFF Fix Type
16.10.3 162067ms 3D
17.06.0 29372ms 3D
18.02.0 72894ms 3D
18.05.1 215151ms 2D

Looks like an issue with the Legato GNSS software. Sigh.

ciao, Dave