Getting Started Tutorial - Not all Functions Working - Firmware not Known from AirVantage


I need some help understanding some issues I’m having after completing the Getting Started Tutorial for the MangOH Red with WP7702 using Sierra Wireless SIM.

I am using the mangOH Red + WP Module [non-Octave] tutorial at the following page:

Upon Completing the tutorial, I can see that the WP7702 is online, The timeline shows LWM2M Data coming into the dashboard.

The issue is that not all the functions are working and I’m getting warnings from the dashboard.

  1. The LED Switch and Set Blink Interval commands fail and do not work

  2. Not all the sensors are updating, or take a very long time to update

  3. The Firmware Version shows a warning saying : “The firmware version returned by the system is unknown from AirVantage Cloud. Please upgrade to latest.”

First I tried using the firmware .exe provided from the following link and had the above issues:

Then I tried building from source using the guide in the tutorial listed above, This was using CLI leaf manager int he MangOH VM. For this particular module, I could use firmware version 19.x or 20.x so I tried both and was not able to get any further than using the exe.

Has anyone else seen this issue that can provide some insight?

Hi Kevin,

If data is coming from the device into AV, that’s good news.

To check the firmware version, please ssh your device and run the cm info command. Please share with us the result so that we can try to help you.
Also, that would be great to give us the result of app status command too, so that we can see what Legato app is running on your device.


Okay, I have just updated the firmware using the .exe provided at the following address. I selected the WP77xx .exe file:

Here is the results from the following commands:

“cm info”

“app status”

Also, here is a snippet of the firmware warning error when I expand the warning


Could you provide the result of legato version as well please?


Hi Kevin,
Please disregard AirVantage message about upgrading your firmware. You have the latest firmware, and AirVantage does not have it yet, hence the message. It should not affect the way AirVantage & your device are interacting.

Okay, thank you. I will disregard firmware version warning.

Can we explore why the LED switches are not working within the dashboard?

I suspect you don’t have the right “RedSensorToCloud” application associated with your device in AV (the path seems different from what your command tries to do)
Try maybe to use “RedSensorToCloud 2.0” (menu Developement>My apps in AirVantage)

How can I tell which app is associated with my device in AV?

The RedSensorToCloud 2.0 app found in (menu Developement>My apps in AirVantage) seems to have the same commands and parameters shown in the initial dashboard app. That is, “Switch LED and Set blink Interval”.

Are you able to see my dashboard?

How can I see what is being sent from the dashboard vs what is expected at the device side?

Interestingly, when trying to modify the command widget, when trying to create commands for the mangOH source, I can only choose commands from the following application.