Fundamentals - WP7607 Can't develop and test applications

Hello everyone,

I’m new to the mangOH Green and been trying to get my mangOH Green running.
I followed all the steps described in the Fundamentals PDF: but I can’t get past chapter 4.

Since there was no USB drive included in my box, I downloaded the drivers from ( + I installed the VM with the following ova mangOH Development - Ubuntu 18.04 - 20200330.

However, when I want to run the Hello World example using the following code in Ubuntu in the VM I run into the following problem:

Does anyone know what I’m doing wrong?


What do you have in $LEGATO_ROOT

That’s the point.

There is no sign of the apps folder which is why I think I missed something during the setup but I don’t know what this might me.

Probably you need to search where the legato framework is.

Looks to me you didn’t set up anything. LEGATO_ROOT is the null string and your home directory just contains the default Ubuntu folders.

I mean I’ve tried everything so far.
Even installing Legato using this official tutorial ( is not working. And this is not even included in the Fundamentals PDF.

Seems it should be single line command

Thanks for the tip @jyijyi.

I just removed the mangOH Development - Ubuntu 18.04 - 20200330 VM and added it again.
There are two things I noticed. First, in the description it says that the VM enables "development for mangOH Yellow and mangOH Red boards. So this means the .ova I can find at ( does not support the mangOH Green board? And second, in contrast to the Fundamentals PDF there is no option to select “Enable VT-x/AMD-V” under Hardware Virtualization. Might this also be a problem?

Moreover, when I start the VM it says that it cannot find the shared folder which is true since there wasn’t a folder named “dfrey” in the first place. Should I add it manually?

When I tried to install some updates using the Software Updater I was prompted to type in a password. I never set a password so the question is what can it probably be?
I tried out “legato” as it’s stated in the Fundamentals PDF: “The Linux virtual machine’s legato User password is “legato”. You will need to use this to unlock the VM if you manually lock it.” which is also not working.

I suggest you install a new clean Ubuntu VM machine and then compile the application via Developer studio(although it is going to be end of life, but it is easy to use)

But I guess installing something that’s been outdated for 2 years can’t be the solution to the problems I’ve been facing.

No idea how to fix your VM problem …
If you just want to compile and download a simple app to module, you can try to install the developer studio tool on fresh ubuntu VM machine

I just installed Developer Studio on Windows and am now being asked to type in a root password.
The Fundamantels PDF says that there is no password necessary but typing nothing in is not the solution.

Seems your module has set the password

What does that mean and how can I fix it?

is that you have set a login password on your module?
On my side, I can just type usename to be “root”, ignore the password , I can still connect to my module.

I haven’t set a password on my module.

I don’t see problem with developer studio in linux, you can give a try

I just found out that it was “sierra”.

I can’t seem to find Developer Studio for Linux at the moment which is why I’m going back to trying out the CLI as described in the tutorial.

Does anyone know why the following command is not working?


You need to type “source ./bin/configlegatoenv” after you download the legato package

Thanks @jyijyi.
I typed in “leaf shell” and it worked too.

Now I’m trying to run the helloWorld app but it seems like I can’t start it.