Firmware Update: Customer Config OK; Carrier Fails


#1

Continuing from earlier thread, as the forum won’t let me post any more in that thread - and suggests starting a new one:

Replies to questions from asyal:

what version of mangoh are you using rev7 or rev8? Your module sku looks pretty old.
Can you do app status?

Yes, it’s quite old - one of the ones given out at the Sierra Wireless Developer Summit in Paris last year.

How would I check the mangOH Rev? Or “app status”?

Can you download FW again and carrier again? This time with boot pin to ground for both the cases and post the image at completion at each time.

Sure - firmware:

Also post the at data I asked earlier again. Just want to double confirm everything is ok before you start

at
OK

at!priid?
PRI Part Number: 5501011
Revision: 01.15

Carrier PRI: None

OK

at!package?
9101011_5501011_WP8548_07.09.02.00_00_DevKit_001.015_000

OK

ati
Manufacturer: Sierra Wireless, Incorporated
Model: WP8548
Revision: SWI9X15Y_07.09.02.00 r31541 CARMD-EV-FRMWR1 2016/03/31 20:05:28
IMEI: 359377060000865
IMEI SV: 41
FSN: LL516403850102
+GCAP: +CGSM

OK

ati8
Legato Ver: 16.01.2_9e91388c2b14980a4d419259910a4d65_modified
Yocto Ver: SWI9X15Y_07.09.02.02 Fri Apr 15 02:39:24 PDT 2016
OS Ver: Linux version 3.14.29ltsi-13c67b16ff_922830eb31 (gsmbuild@CARMD-EV-FRMWR1) (gcc version 4.9.1 (GCC) ) #2 PREEMPT Fri Apr 15 02:38:16 PDT 2016
LK Ver: 1.3.0_a50272dbb2
RootFS Ver: unknown
UserFS Ver: unknown

OK


FTDI USB Serial Device - where is ttyUSB0?
#2

The forum would only allow me to put one image in the post. So here’s the 2nd screenshot

Carrier - still fails:


#3

Everything looks ok for both firmware and carrier download based on the at data you show here.
I’ll need to check on that version of module as to the response we get for carrier download.


#4

OK - so it’s actually worked?

Great!

:grin:


#5

FDT error code 4 means the tool failed to communicate with the module.

The boot pin appeared to be used to start the update (not sure why). The boot pin must be de-asserted to allow the module to start-up properly. If the pin assertion was not removed in time for FDT to perform a sanity check after update, the error will be thrown.


#6

So if I had flipped the switch at the point where it said “Resetting device …” it might all have worked without reporting any error?


#7

It should have but you reported it didnt. Either way, you are good to go.
Can you connect to a cell network?


#8

But I wasn’t flipping the switch back; if it was in the instructions, I missed that bit.

But, yes; it connects to the cell network - I have the SMS demo working.

:grin:


#9

:slight_smile: Everything seems to be working for you.


#10