Firmware not upgraded with swiflash

using ‘swiflash’ tool on mangOH red board WP7702 to upgrade firmware with custom built kernel (with enabled BT module in kernel)
it gives no error, but firmware not upgraded in fact

this is before update:

and this is after:

commands I used to update:

> ssh root@192.168.2.2
> microcom /dev/ttyAT
AT!BOOTHOLD

> swiflash -m “wp77xx” -i WP77_Firmware.skp

Have you tried without the boothold? I’ve never had to use it with swiflash. You can try fdt2 on Windows as an alternative.

I got no such issue with official firmware WPx5xx_Release16.1_GENERIC.spk.

Two alternative ways to upgrade module with custom firmware:
Case 1:

  1. Install swicwe tool
  2. To build your own combined image custom-firmware.spk from the following components:
    Modem Firmware: modemFW.spk
    MCU Firmware: mcuFW.cwe
    Linux Distribution: boot-yocto.cwe
    Base Legato System: legatoz.cwe

you need to launch the following command line:
swicwe -o custom-firmware.spk -c modemFW.spk mcuFW.cwe boot-yocto.cwe legatoz.cwe

Case 2:

  1. Download the Firmware .SPK file according to your carrier:
    R16.1 (Generic — GCF/PTCRB) — WP7502, WP7504, WP8548
    R16.1 (AT&T) — WP7504, WP8548
    R16.1 (Sprint) — WP7504

  2. Connect the target’s (e.g mangOH) USB cable to your host

  3. Open a terminal and execute the Legato command line:
    fwupdate download 192.168.2.2

yes, tried first of all without boothold, also tried Windows tools (Developer Studio) - also give no error, and not flash