External sim card problem

Hi,
I have installed mangOH Yellow Latest Software Images revision: 0.6.0 ( without Octave ) from official mangOH website. I have changed sim slot from EMBEDDED to EXTERNAL_SLOT_1, setup APN, but system says that module is not registered on network

when I want to connect I have got error:

ExternalSim1

SIM card is not faulty. We checked the sim on FX30.

Thanks for help in advance

You can use the the same FW as fx30 and retry

I can’t because on FX30, SPI doesn’t work for a change :slight_smile:
You are saying, it is impossible to use external sim card on mangOH yellow with “Latest mangOH yellow 0.6.0 firmware without Octave”. Firmware without Octave can use only embedded sim which connects with Octave only :smiley:?

didn’t you already using external SIM on “Latest mangOH yellow 0.6.0 firmware without Octave”?

What I mean is you use the FW of FX30 and download to the mangoh board.

Do not understand you. I have inserted SIM to mangOH with 0.6.0 it does not work. I do not want to use Firmware 16.10 from FX30 on mangOH yellow. it does not make any sense for me.

What is the actual module in your fx30? Wp8548?

What is the actual module on your mangoh yellow? wp77?

FX30 WP8584. Yellow WP77. I used FX30 to check sim card only. I want to know if it is possible to use external sim slot on mangOH yellow with latest dedicated software 0.6.0.

Othet user is ok to use sim card on mangoh yellow

You might try some generic wp77 fw first

you should be able to use external sim card with non-Octave fw. It seems more like your APN is not set.

APN is set correctly (please look at screenshots I sent). I tested the same sim card with the same settings on FX30 and mangOH Red. Everything works without issue.

I have got another finding :
I tested the same sim card, with the same settings and the same firmware 0.6.0 non-Octave on mangOH yellow, processor WP77 WITHOUT embedded sim card and it works correctly.

It looks like the issue is on processor WP77 WITH embedded sim card.

you can select the active sim by AT!UIMS.
Also you can try the generic WP77 FW and see if there is any problem.

AT commands does the same what console command cm sim select <EMBEDDED | EXTERNAL_SLOT_1 | EXTERNAL_SLOT_2 | REMOTE> . It switching between Embedded and External slot. But it does not connect to internet via external sim.

I will try generic older legato version later on.

then you can try some WP77 FW to get more clue:
https://source.sierrawireless.com/resources/airprime/software/wp77xx/wp77xx-firmware-release-13/#sthash.ng6fZnGU.dpbs

Same problem here… did you solved?
Thanks
gian

No. It does not work.

You said “you will try generic older legato version later on”,.does it work???

I tried only one older version and did not work (i do not remember which one, it was some time ago). When I informed customer, that downgrade would be required he said, he cannot trust the unit and he chose FX30. I did not continue working on this.