Excess current consumption in ultra low power mode?


#1

I have a Mangoh Green board that I’m using to evaluate the wp-series modules for power consumption

Idle, with SW401.8 active, the radio off, and devMode disabled, I measure 24mA across the CN1204 power supply selection jumper.

When I enter le_ulpm_ShutDown(), current drops to 10mA.

The WP8548 technical reference suggests that I should see <1mA in ultra low power mode.
Is there a hardware or software tweak needed to see that low current draw?

Here’s my configuration:

root@swi-mdm9x15:~# legato version
16.10.3_7776bb75a488e0db67b0d24975b46dd0_modified

root@swi-mdm9x15:~# cm info
Device: WP8548
IMEI: 359377060015772
FSN: LL604200091305
Firmware: SWI9X15Y_07.12.09.00 r34123 CARMD-EV-FRMWR1 2017/04/26 23:34:19
Bootloader: SWI9X15Y_07.12.09.00 r34123 CARMD-EV-FRMWR1 2017/04/26 23:34:19
priIdPn: 9905383
priIdRev: 01.07
skuId: 1102816

Here’s a the log output from entering ultra low power mode

Jan 6 00:09:52 swi-mdm9x15 user.info Legato: INFO | helloWorld[1319]/helloComponent T=main | helloWorld.c _helloComponent_COMPONENT_INIT() 8 | Set timer to 10 second
Jan 6 00:09:52 swi-mdm9x15 user.debug Legato: DBUG | helloWorld[1319]/framework T=main | le_ulpm_client.c le_ulpm_ShutDown() 752 | Sending message to server and waiting for response : 0 bytes sent
Jan 6 00:09:52 swi-mdm9x15 user.err kernel: [ 266.604608] qup_i2c qup_i2c.0: QUP: I2C status flags :0x1300c8, irq:187
Jan 6 00:09:52 swi-mdm9x15 user.err kernel: [ 266.604700] qup_i2c qup_i2c.0: I2C slave addr:0x3a not connected
root@swi-mdm9x15:~# Jan 6 00:09:55 swi-mdm9x15 user.debug SimpleRIL[1323]: [SIMPLE_RIL_INTEGRITY]
Jan 6 00:09:55 swi-mdm9x15 user.debug SimpleRIL[1323]: simple ril init complete
Jan 6 00:09:55 swi-mdm9x15 user.debug SimpleRIL[1323]: [SIMPLE_RIL_INTEGRITY]
Jan 6 00:09:55 swi-mdm9x15 user.debug SimpleRIL[1323]: simple ril NW reg init complete
Jan 6 00:09:55 swi-mdm9x15 user.debug SimpleRIL[1323]: SUCCESS (UNCONDITIONAL)
root@swi-mdm9x15:~# packet_write_wait: Connection to 192.168.2.2 port 22: Broken pipe


#2

Hi @fkoran,

There’s an application note on measuring current consumption in ULPM on mangOH. Hardware mods are required.

https://source.sierrawireless.com/resources/airprime/application_notes_and_code_samples/airprime_wp_ulpm_power_measurement_application_note/

Additional considerations:

  1. POWER_ON_N (SW401.1) should be OFF (switch open) to achieve the lowest power consumption in ULPM.
    Note that the module needs POWER_ON_N to be ON after power is applied for the module to boot.
    Once booted, it can be switched to the OFF position to improve power consumption even further.

  2. Ensure autosleep is enabled - should be by default unless you’ve modified/disabled the script.

  3. Disconnect the USB OTG cable to allow the module to enter USB-SS mode.

Raf


#3

Thanks, that’s exactly what I was looking for