Ethernet IoT exp. Card is not working with mangoh red

I am using a WP7702 cell modem with my mangoh red board. I have went through all of the initial setup directions in the getting started guide. I am able to see location, pressure, light data in the airvantage cloud server. Now I am trying to use mangoh red as a gateway for raspberry pi 3 b+ to send pings to the airvantage clould server (i.e. raspberry pi pings (from its command line) message through its Ethernet port >> through Ethernet cable >> to Ethernet port on the Ethernet IoT expansion card inserted into mangoh red >> mangoh red sends ping message to the clould server. Is this possible if so, how can this be done. Please provide detailed steps to do so because my background is not programming its electrical engineering.

Any help would be appreciated.


Didn’t you are already doing this?

I did not get this error before. I’ve tried to give myself permissions to the file “export” using the chmod command however it returns no such file or directory. The echo commands below require me to access a file which is stored under “other locations” >> “computer” >> “sys” >> “class” >> “gpio” >> “export” (I am using a linux laptop with ubuntu). The export file type is unknown.

echo 2 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio2/direction
echo 1 > /sys/class/gpio/gpio2/value

Are these commands supposed to be entered from the command line? If so why do I get permission denied when entering them?
Screenshot from 2020-08-16 11-43-02

Of course these commands should be entered in module console instead of that in your computer.

Oh, I see.

I will try and let you know if it works.

Thank you

@jyijyi Okay the first echo command worked after ssh’ing into the mangoh red. Now when I type the second command echo out > /sys/class/gpio/gpio2/direction it says that this directory does not exists. (see below)

What did you see in /sys/class/gpio/gpio2/

Btw, the first command should be

echo 2 > /sys/class/gpio/export

Okay, what I see when entering ls /sys/class/gpio/gpio2 is this

Then it should be working now

So this is what I am seeing after typing ifconfig

Pls see here