Eth address 192.168.0.1

Hi - I wanted to use mangoh green with the plain ETH only (for a moment).
My local network is 192.168.0.0/24, with router at 192.168.0.1.

I set up the ETH to static address 192.168.0.50. I set it frist
I can ssh to it. I can ping it from outside and I can ping computers on my network from inside.
iptables are empty - all policies set to ACCEPT.

HOWEVER: I can’t ping the router (192.168.0.1) from the box!
And without router/gateway I can’t connect to the Internet.

I even did experiment setting ETH from DHCP (which is offered by the router. And the box GOT the address, settings, but still was not able to ping the router or get outside.

I’m a bit puzzled by this. Is there anything else I could possible check?

Best regards,
Miroslaw

Hi Miroslav,
Did you add ‘gateway’ IP ( gateway - IP of your router ). You will find sample settings below.

iface eth0 inet static
hwaddress ether 00:00:00:00:00:00
address 192.168.1.222
netmask 255.255.255.0
nameserver 192.168.1.1
broadcast 192.168.1.255
gateway 192.168.1.254

Regards

Bartek

Hi Bartek,

of course I added it. Look at this shell session:

root@swi-mdm9x28-wp:~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 46:53:F2:C7:41:2E  
              inet addr:192.168.0.50  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:185 errors:0 dropped:0 overruns:0 frame:0
              TX packets:200 errors:0 dropped:0 overruns:0 carrier:0
....
root@swi-mdm9x28-wp:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 ecm0
192.168.225.0   0.0.0.0         255.255.255.0   U     0      0        0 bridge0

root@swi-mdm9x28-wp:~# iptables -L -n
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination     

And I’m connected (ssh) via eth. ipv6 is disabled.

I can ping 192.168.0.11 - another device on the network. I can obviously ping my laptop (77).
But I can’t ping 192.168.0.1 - the router. Moreover. It has port 80 open (administration) and this happen when I try to connect:

root@swi-mdm9x28-wp:~# telnet 192.168.0.1 80
telnet: can't connect to remote host (192.168.0.1): Protocol error

There is no connection to this particular IP because of some weird reasons. That is why it is so puzzling.

Any ideas?

Best regards,
Miroslaw