Error while Kernel configuration using menuconfig


#1

Hi,

I am building kernel for MangoH WP8548 board in linux (3.13) host. I have followed the below steps :

  1. Downloaded Legato Distribution Source Package i.e, Legato-Dist-Source-mdm9x15-SWI9X15Y_07.10.04.00.tar.bz2
  2. tar -xvjf Legato-Dist-Source-mdm9x15-SWI9X15Y_07.10.04.00.tar.bz2
  3. cd yocto
  4. export LEGATO_BUILD=0
  5. make image_bin
  6. . ./poky/oe-init-build-env
  7. cd …/build_bin
  8. bitbake linux-yocto -c kernel_configme -f
  9. bitbake linux-yocto -c menuconfig

When i do 9th step i.e, menuconfig to configure the kernel, configuration window will come and immediately vanishes. So i’m not able to configure the kernel.

menuconfig will work perfectly in my host linux machine by poping a window to set the configurations.

Am i done anything wrong? Please help me to get the window popup to configure.

Thanks in advance


Correct way to configure and rebuild kernel
#2

I haven’t seen that issue before. I noticed that you mentioned Legato-Dist-Source-mdm9x15-SWI9X15Y_07.10.04.00.tar.bz2. Is there a reason why you’re not using Legato-Dist-Source-mdm9x15-SWI9X15Y_07.12.09.00.tar.bz2?


#3

No reason to use Legato-Dist-Source-mdm9x15-SWI9X15Y_07.10.04.00.tar.bz2. We can use newer also.

Did any changes made in Legato-Dist-Source-mdm9x15-SWI9X15Y_07.12.09.00.tar.bz2? regarding menuconfig?


#4

there is no change in menu config


#5

I’m not aware of any reason why menuconfig would differ between the releases, but you might as well give the newer release a try and see if that resolves your problem.


#6

I have tried in Legato-Dist-Source-mdm9x15-SWI9X15Y_07.12.09.00.tar.bz2 also but getting same issue


#7

Yes i am building in the same directory (build_bin)


#8

Are any errors printed at the time that menuconfig exits?