Error while bilding on mangOH_16.10


I am new to mangOH. Have mangOH Red board with WP7502 module loaded with legato 17.06 by using latest mangoh from git and firmware info below.
Device: WP7502
IMEI: 357851070004614
FSN: P3653300011203
Firmware: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Bootloader: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
PRI PN: 9906352
PRI Rev: 01.05
Carrier PRI Name:
Carrier PRI Rev:
SKU: 1103114
MCU Version: 001.011

I came to know recommended Legato AF was 16.10.3 with firmware release of 14.
I have taken 16.10.3 legato AF and mangOH 16.10 from github.
I am able to build legato AF, while coming to mangOH
given “make --include-dir=$LEGATO_ROOT wp85” to build. But its giving error

-t wp85
-i “/home/iram7/legato_framework/legato/interfaces/supervisor”
-i “/home/iram7/legato_framework/legato/interfaces/positioning”
-i “/home/iram7/legato_framework/legato/interfaces/airVantage”
-i “/home/iram7/legato_framework/legato/interfaces/modemServices”
-i “/home/iram7/legato_framework/legato/interfaces”
-i “/home/iram7/legato_framework/legato/interfaces/atServices”
-i “/home/iram7/legato_framework/legato/interfaces/wifi”
-i “/home/iram7/legato_framework/legato/interfaces/secureStorage”
-i “/home/iram7/legato_framework/legato/interfaces/logDaemon”
-s “/home/iram7/legato_framework/legato/modules/WiFi/service”
-s “/home/iram7/legato_framework/legato/components”
-s “/home/iram7/legato_framework/legato/modules/WiFi/apps/tools/wifi”
-s “/home/iram7/legato_framework/legato/apps/platformServices/airVantage”
-s “/home/iram7/legato_framework/legato/apps/platformServices”
-s “/home/iram7/legato_framework/legato/apps/tools”
-s “/home/iram7/mangOH_work/apps/GpioExpander/gpioExpanderService”
-C -g -X -g -L -g
A system definition must be supplied.
Makefile:25: recipe for target ‘wp85’ failed
make: *** [wp85] Error 1

can anyone help me out regarding this one.
which version of mangOH is recommended.

I have tried to update firmware release 14 with fwupdate download (legato AF 16.10.3). Do we need to have same legato AF version that the module contains??

$ fwupdate download WPx5xx_Release14_GENERIC_SPK.spk
Connecting to service …
Connecting to service …
Download started …
Error in download

Please help me out.

Thanks in advance.


The latest release for the WP7502 is Release 14 which includes Legato 16.10.3. There have been many Legato releases since that time and I think that Legato continues to get better. The mangOH repositories target the latest stable version of Legato (currently 17.10.0). The mangOH repositories may work with previous versions of Legato, but we don’t really put any effort into maintaining compatibility with previous releases.

It’s unfortunate that the WP85 and WP750x have not had a new release in so long. It’s not clear to me why that’s the case. Perhaps someone will respond if you ask in the WP module forum.


thanks for the suggestion.