Error when connect to mobile networks

I tried to connecting mangOH green to the mobile network, but when I ran “cm radio” and received “Current RAT: Module not registered on network, RAT not available”
Can you have me resolve this issue?

The information are:
root@swi-mdm9x28:~# cm sim
SIM card is inserted and unlocked (LE_SIM_READY).

root@swi-mdm9x28:~# cm sim info
ICCID: 89332401000004678492
Home Network Operator:
IMSI: 234507089445273
Phone Number:
root@swi-mdm9x28:~# cm data
Index: 1
PDP Type: IPV4
Connected: no
root@swi-mdm9x28:~# cm radio
Power: ON
Current Network Operator: VIETTEL
Current RAT: Module not registered on network, RAT not available
Status: Not registered but currently searching for a new operator (LE_MRC_REG_SEARCHING)
Signal: Very strong signal strength (5)
PS: Packet Switched Not registered (LE_MRC_REG_NONE)

root@swi-mdm9x28:~# cm info
Device: WP7607
Firmware Version: SWI9X07Y_02.25.02.01 000000 jenkins 2019/01/30 08:13:05
Bootloader Version: SWI9X07Y_02.25.02.01 000000 jenkins 2019/01/30 08:13:05
MCU Version: 002.011
PRI Part Number (PN): 9908099
PRI Revision: 001.000
Carrier PRI Name: GENERIC
Carrier PRI Revision: 002.056_000
SKU: 1103511
Last Reset Cause: Reset, User Requested
Resets Count: Expected: 428 Unexpected: 41

Thank you!

Hi, Tam.

Where did you get your SIM from? Is it a VIETTEL SIM?

If you’re trying to connect to VIETTEL, then it looks like the APN is not correct. It looks like VIETTEL’s APN is v-internet.



Thank Mr. jchitty,

  • Yes, it is a VIETTEL SIM. My SIM in Viet Nam.
  • I have connected to mobile network and AirVantage sever with this SIM.
    But, when I delete the register of mangOH green board on AirVantage server, then I tried to connect to mobile networks and AirVantage server again. This issue occur.
    ==> I have tried with a new AirVantage account , but can’t resolve this issue.
    ==> I also tried with another SIM.

Hi Tam

Please note that some WP module is not supported to connect to network in Vietnam.
Please use WP8548 or WP76xx.

If you still face issue please contact me.

Thong Nguyen

Thank Mr. Thong,

I have resolved this issue by re-install latest firmware in ULR:

Tam Nguyen