Enabling built-in WLAN WiFi on mangOH Yellow with WP7702 WP77XX

Hello Everyone,
I am using mangOH Yellow with WP7702. I am not able to simply enable built-in WiFi WLAN.

I am using LEAF in my environment.
Distribution: mangOH-yellow-wp77xx_0.7.0
The built in Legato version on this distribution: 19.11.3-1-g8c030edad_xxxx
Whenever I do this; i get error:

# wifi client start
ERROR: le_wifiClient_Start returns ERROR.

I believe the WiFi on Yellow is a Cypress WiFi chip. What I have tried so far.

I have tried to follow this guideline:

It says, we have to apply patch as mentioned in

But this is for RED and Not for YELLOW!

I tried to follow only the " Patch Legato" part.

It says, we should get patch from “GitHub - mangOH/Legato_patches: Bug fixes for Legato that have identified and fixed but have not made it into the current Legato version.”.

But this git does not have any patch for version 19.11.3-1. The latets available is "19.1.0"

When I tried to patch using “19.1.0” version, few of the patched failed
apply_legato_patches_untracked.sh …


  1. Also, in this section and the next (" Rebuild your mangOH"), the paths are little mixed up, not generically mentioned.

  2. I am still confused if the WiFI would be available as wlan0 or wlan1 for the builtin WiFI on Yellow.

So, finally it is all mixed up.
Hence, I request you / anyone to please point me to a proper guide /documentation to enable the built-in WiFi on Yellow. (with WP77XX)

(And I am surprised why it is not enabled by default!)

Thanks in Advance.

Additionally, I could not find " brcmutil/etc/init.d/cywifi.sh"
Where are the “brcmutil” and “cywifi.sh” located in the code base?
Can anyone please point me out?

Did you ever flash a generic wp77xx release onto your yellow board? I have seen this issue and we got it to go away after flashing a mangoh-yellow official release to the board.

hi, @jameswollaeger Thanks for your response.
I am relatively new to the mangOH-Legato ecosystem.

  1. I bought the board from market, and I assume that it is pre-flashed with yellow binaries/file system etc.

  2. I have built the latest mangoh+Legato by following Yellow guide book. It generated an “.update” file which flashed. I never flashed any other generic images.

  3. Could you please point me to the official Yellow binary? the path/site link? is it the linux CWE file or the SPK files?

  4. The problem is their guideline is itself not conforming to their release baseline. The files are missing and the patch they mentioned is not available in the git for this version. I could not even find the cywifi.sh file in the latest code base and the previous github links give 404 not found. (like this one )

  5. Could you let me know wchih yellow baseline + legato version you are using (where built-in CyWifi is working).

Thanks in Advance.

@kuntalmukherjee :

  1. We have purchased from both digikey and Richardson RFPD here in USA, so guaranteed they were never used by anyone.
  2. Ok. if you flash any spk file that could overwrite files that came from factory.
  3. You can find the official here: mangOH Yellow Resources - Software - mangOH
  4. Agreed completely there are issues if you need to build your own yocto image that includes wifi. We have built our own linux image using the official yocto download from sierra WP76xx sierra Source website: https://source.sierrawireless.com/resources/airprime/software/wp76xx/wp76xx-firmware-release-16,-d-,0,-d-,1-components/#sthash.coz8u70U.dpbs
    We had to add meta-mangoh layer from github and then apply the changes from this branch to the master that has fixes for wifi: GitHub - mangOH/meta-mangoh at modules_dep_wifi_workaround
  5. We are using R16.0.0 linux build (wp76xx), Legato 19.3.3 release as its labelled ‘stable’

One last thing. I will say that wifi will always fail with -6 code after a software update or crash induced reset. If you type ‘reboot’ into the command line, the wifi should work after that.

Hi @jameswollaeger , many thanks a lot for your response. After flashing the SPK file, that came with mangoh release, it seems to be working!!

1 Like