DS 5.0 L16.10.1 Error with tool chain "unsupported on this system, attempting to build anyway."


After updating DS and moving to 16.10.1 i am getting the following errors. it works fine in 16.7

I am building on a 32bit system .

15:01:18 **** Incremental Build of configuration Target_Legato_Release for project combapp ****
Info: Configuration “Target_Legato_Release” uses tool-chain “Legato Application Framework GCC (Native)” that is unsupported on this system, attempting to build anyway.
make -I /root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato all
cd …;mkapp -t wp85 -o /tmp/build/combapp/Target_Legato_Release -w /tmp/build/combapp/Target_Legato_Release -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/positioning” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/airVantage” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/secureStorage” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/logDaemon” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/supervisor” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/atServices” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/modemServices” -i “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/interfaces/wifi” -i combwp85/include -i combwp85/include/ciis_framework -i combwp85/include/ciis_protocol -i combwp85/include/drivers -i combwp85/legato/include -i combwp85/include/chips -s “/root/legato/packages/legato.framework.16.10.1.wp85-wp750x-201701111029/resources/legato/components” -s “.” -L -lssl -L -lcrypto combapp.adef --append-to-version=20170213150118
sh: 1: null/nullgcc: not found
Warning: Failed to receive sysroot path from compiler ‘null/nullgcc’ (errno: Success).
Failed to receive the sysroot path from the compiler ‘null/nullgcc’. Compiler ‘’ exited with code 127
Makefile:48: recipe for target ‘target’ failed
make: *** [target] Error 1

15:01:18 Build Finished (took 132ms)


Running it from the command line using Dec 23 toolchain and fresh build of legato works fine.

i did a swiflash -r/-i to load the latest home built yocto/legato

cm info;uname -a;legato version
Device: WP8548
IMEI: 359377060030102
FSN: LL621100270906
Firmware: SWI9X15Y_07.11.11.00 r33161 CARMD-EV-FRMWR1 2016/09/20 16:36:44
Bootloader: SWI9X15Y_07.11.11.00 r33161 CARMD-EV-FRMWR1 2016/09/20 16:36:44
priIdPn: 9905383
priIdRev: 01.02
skuId: 1102816

Linux swi-mdm9x15 3.14.29ltsi-a00e464379_b0ce579abb #2 PREEMPT Fri Feb 10 14:36:07 SAST 2017 armv7l GNU/Linux



Hi @gregnietsky

Indeed, it seems to be an issue with the 32 bits toolchain bundle for Legato 16.10 (reproduced on our side).
Working on it; will keep you informed when we’ll have a fix.


Hi @gregnietsky

A new Legato 16.10.1 bundle for 32 bits hosts has just been made available.
Please check your Packages perspective and install the new version (build qualifier 201702141553).
Then migrate your project to this new version.

You should uninstall as well the old version (build qualifier 201702011325), otherwise you’ll potentially have troubles when creating new projects.


I can confirm it is resolved thank you very much.


I am getting a similar error with Dev Studio 5.2, using the VM provided. As far as I know though, mine is a 64 bit system, not 32, Legato 17.07.02 running on Ubuntu 16.04, with a WP7601 device.
I’m not really sure everything is setup right as I’m having to put in the full path to commands and $LAGATO is not defined. It builds fine in the dev studio, but the paths aren’t set up correctly in the CLI.
Is there a fix for the WP7601 as well?


Hi @Evets

To get your CLI ready to work with a given Legato version, if your DS environment is already working, all you need to do in your shell is:

$ source $HOME/legato/packages/legato.sdk.X.Y.Z/resources/configlegatoenv

(Assuming your packages are installed in $HOME/legato/packages, which is the default)
You’ll need to do this every time you open a new shell; or to add it to your .bashrc file.


Thank you @daav for replying!

It worked, but here are the issues I’ve seen before when I ran some of the scripts:

No toolchain found for target ‘ar7’.
Unable to find compatible cross-build toolchain for target ‘ar7’.
No toolchain found for target ‘ar86’.
Unable to find compatible cross-build toolchain for target ‘ar86’.
Toolchain specified for target ‘wp76xx’ is invalid.
Unable to find compatible cross-build toolchain for target ‘wp76xx’.

What else am I missing? I can connect with the board OK with the IDE, although it won’t properly finish the connection. It fails when it tries to read the local disk with an io exception, then it skips all the additional things it does when it connects. It does remain connected though and I can do commands, etc. The biggest problem is I can compile code, but can’t put it on the device with the IDE. Here’s what I get when I do:

13:43:37 **** Incremental Build of configuration Target_Legato_Debug for project ModemDemo ****
Info: Configuration “Target_Legato_Debug” uses tool-chain “Legato Application Framework GCC” that is unsupported on this system, attempting to build anyway.
make -C Target_Legato_Debug all
make: Entering directory '/home/mangoh/Documents/Repository/ModemDemo/Target_Legato_Debug’
cd …;mkapp -t wp76xx -o Target_Legato_Debug -w Target_Legato_Debug -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/supervisor” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/wifi” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/positioning” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/modemServices” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/airVantage” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/secureStorage” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/atServices” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/airVantage/legacy” -i “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/interfaces/logDaemon” -s “.” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/apps/platformServices/airVantageConnector/apps/test/suspendResume” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/apps/platformServices/airVantageConnector/apps/test/timeseries” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/apps/platformServices/airVantageConnector” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/airVantage” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/modules/WiFi/apps/tools/wifi” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/positioning” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/secStore” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/uartMode/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/modemServices/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/audio/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/apps/tools” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/3rdParty” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/apps/platformServices/airVantageConnector/apps/test/assetPush” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/fwupdate/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/modules/WiFi/service” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/airVantage/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/apps/platformServices/airVantageConnector/apps/test/session” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/fwupdate” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/positioning/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/devMode” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/secStore/platformAdaptor/default” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/modemServices” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/atServices” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components” -s “/home/mangoh/legato/packages/legato.framework.17.6.0.wp76xx-201708181414/resources/legato/components/uartMode” -C -g -X -g -L -g ModemDemo.adef
sh: null/nullgcc: No such file or directory
** WARNING: Failed to receive sysroot path from compiler ‘null/nullgcc’ (errno: Success).
Makefile:37: recipe for target ‘target’ failed
make: Leaving directory ‘/home/mangoh/Documents/Repository/ModemDemo/Target_Legato_Debug’
Failed to receive the sysroot path from the compiler ‘null/nullgcc’. Compiler exited with code 127
make: *** [target] Error 1

13:43:37 Build Finished (took 313ms)

I’m just compiling the helloWorld sample app. Any help would be appreciated.


Turns out there’s an “extractor” script that that extracts the toolchains. None of this is mentioned in the documentation. I’m running this in a VM on Win 10. The Windows version of Dev Studio gets all the way through and launches the VM legatoDocker and then connects with the device (in my case a WP76xx) and then fails as I already mentioned. When I run it again (because the device is already connected), it seems to work, and packages up the exe that was compiled and tries to rsync it to the device, which doesn’t produce any errors, but I get a dialog that says the project has 2 errors. But nothing else mentions that, and there are no specifics.

Additionally, the Dev Studio REQUIRES that the source line @daav mentions above MUST be put in the .bashrc for the Dev studio to work properly as well, since it’s just running the make and other commands in a bash shell. I have the virtual 16.04 VM working now except I will have to update the Legato framework on the device from the release as it’s not the same as the build. Oh and the Windows version isn’t at 5.3 yet, which was also a necessary component. My colleague has a non-virtual ubuntu 14.04 and they are having issues with the IP address for the USB/Ethernet interface, so she is not able to make connection with the device.

Hope this helps others that are having the same issues.


Apparently, there is still something that doesn’t work right. When I try to install my app on the device, it complains because it can’t get the framework version (null) from the device. So, it gives me the choice to continue anyway, and it does OK until:
Run ModemDemo
Execute 3 tasks
Connecting to device
Target is already connected
Build ModemDemo
Project contains error
Install ModemDemo
Install app
Install app ModemDemo.wp76xx.update
Install app ModemDemo.wp76xx.update
Framework version mismatch, install forced
App is already installed with this version
Restart ModemDemo
Execute 2 tasks
Restart app
/legato/systems/current/bin/app restart ModemDemo
Process exited with 0
Refresh target
Execute 4 tasks
Framework status
Framework status
Remote process
(( /legato/systems/current/bin/legato status ) || true)
Process exited with 0
Refresh App list
Refresh App list
Remote process
/legato/systems/current/bin/app info
Process exited with 0
Refresh App bindings
Refresh App bindings
Remote process
/legato/systems/current/bin/sdir list --format=json
Process exited with 0
Find App core files
java.io.IOException: Pipe closed
java.io.IOException: Pipe closed

Which is a similar issue I have when connecting, but different commands. Anyone have any clues?



Hi @Evets

I’m not very clear on what kind of environment you’re using…
Are you using both Linux native and Windows machines?
It’s true that behaviors are not exactly the same between the twos (Windows based DS is using Docker containers on top of a small VM to process the builds).

Please can you start new threads for every specific issue you have? It will be easier to answer to specific problems…


I will answer here but will start a new thread as well.
I am using both and have had issues on both. Some issues like errors when it connects are the same. With the installing issue, it isn’t the same at all. On Windows, when I try to install on the device I get “Project has 2 errors” but nowhere is there an explanation or hint of what the errors are. The logs don’t show anything either. With Linux VM, I get the errors I mentioned above.
I was able to install and run my app AFTER I created a new Legato version that was a copy of the one that is supposed to be in Release 5. While it does run, there are a lot of “can’t find this component”, or some such.

Thanks for replying. I will start a new thread.