DNS on Yellow fails

On Red, we were able to curl to our own endpoint. On Yellow, names and addresses aren’t being resolved. How to fix?
We get a response from the DNS 52.17.142.62, but no response from anything else.
‘cm data connect’ fails in testing the connection.

root@swi-mdm9x28-wp:~# cm data connect
Checking if device ‘rmnet_data0’ is up … ok
Routing inet … ok
Updating /etc/resolv.conf … ok
Testing connection … failed

root@swi-mdm9x28-wp:~# cm data info
Index: 1
APN: iot.swir
PDP Type: IPV4V6
Connected: yes
Interface: rmnet_data0
Family[IPv4]: inet
IP[IPv4]: 10.16.2.183
Gateway[IPv4]: 10.16.2.184
Dns1[IPv4]: 52.17.142.62
Dns2[IPv4]: 52.17.142.62
root@swi-mdm9x28-wp:~# cm sim info
Type: EMBEDDED
ICCID: 89…
Home Network Operator: 208 24
EID: 89…
IMSI: 20…
Phone Number:
root@swi-mdm9x28-wp:~# cm info
Device: WP7702
IMEI: 35…
IMEISV: 4
FSN: 4L9…
Firmware Version: SWI9X06Y_02.32.02.00 c2e98c jenkins 2019/08/30 07:28:21
Bootloader Version: SWI9X06Y_02.32.02.00 c2e98c jenkins 2019/08/30 07:28:21
MCU Version: 002.013
PRI Part Number (PN): 990…
PRI Revision: 001.001
Carrier PRI Name: SIERRA
Carrier PRI Revision: 001.027_000
SKU: 1104405
Last Reset Cause: Power Down
Resets Count: Expected: 8 Unexpected: 0

On Yellow, if you have Octave apps installed you are directed to a private APN. If you disable Octave, then you go to third party site. Could you connect to your server through Octave?

Hello Ashish,
We would like to transmit direct to our own servers.
What’s involved in connecting through Octave? Could you point to the relevant section of your docs? I browsed and see the general overview graphic showing this, but I didn’t find any details.
Thanks