Disable autosleep


#1

Without the USB cable plugged into a PC, the MangOH goes to sleep.
This can be disabled with:

echo off > /sys/power/autosleep

However, doing this in a script from my application’s .adef does not happen early enough in boot to prevent sleeping.

What is the recommended way to disable sleep?

CONFIG_PM_AUTOSLEEP?

Editing an init script?


#2

Hiya,

I got annoyed with this too, and initially was editing the init file.

But I ended up writing a script to do it for me.

I’ve posted instructions and the script here on the forum.

ciao, Dave


#3

Thanks for this. I can also confirm that adding “CONFIG_PM_AUTOSLEEP=n” to the kernel config resolves the issue.