Diagnosing IoT Wifi Card


#1

Hello,

Hoping someone will have a suggestion for me in regards to the WL18xx on Legato/Yocto.

This is my current version info

Legato Version: 17.06.0_f83005aa5145d934e8e282fffc8f7f25_modified
Firmware Version: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Bootloader Version: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Linux Version: 3.14.29ltsi-a00e464379_3f15cd39ad #2 PREEMPT Mon Feb 20 11:11:17 PST 2017

Following the mangoh docs, I should have high enough versions to support the wl18xx module.

dmesg tells me:

[ 0.395299] wl18xx board initialization done

however, if I try wifi client scan I get:

root@fx30:~# wifi client start
successfully called start.
root@fx30:~# wifi client scan
starting scan
DEBUG: le_wifiClient_GetFirstAccessPoint ERROR

logread gives me:

similar logread output if I try to use the legato wifi client api.

Anywhere I can look?


#2

There is a mismatch on the legato version and firmware. Can you move to release 14 firmware?


#3

Thanks for the reply!

Using the spk from https://source.sierrawireless.com/resources/legato/wpx5xxfirmwarerelease14/

Attempting to update (Tried 2 different downloads, didnt look like they had a hash publicly avililbe to reference against)

fwupdate download WPx5xx_Release14_GENERIC_SPK.spk 192.168.2.2
root@192.168.2.2’s password:
Connecting to service …
Connecting to service …
Download started …
Error in download

I’ve tried rolling back my legato version to 16.10, didn’t work with that either.


#4

what hardware are you using?


#5

Sierra Wireless fx30


#6

you need to get the proper firmware for FX30 then. I am not sure whether you can simply drop in the standard sierra WP firmware or not.


#7

Thanks for all your help.

Looks like the last released firmware per https://source.sierrawireless.com/resources/airlink/software_downloads/fx30-firmware/fx30-firmware/ is

Firmware Version: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Bootloader Version: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Linux Version: 3.14.29ltsi-a00e464379_3f15cd39ad #2 PREEMPT Mon Feb 20 11:11:17 PST 2017
FX30 Version: R13.1.2.004

Which is odd considering that per the FX30 datasheet it uses a WP8548-G radio module

Guess its not cross compatible.


#8

Hello ,

I also use the FX30, when I update the framework I receive an error to download
Any ideas as to what’s going on? Thanks you

Best regards,