Developer Studio


#1

Hi,

I would like to use Dev Studio, to debug my target as quick as possible.
But, when I would like to use it, some symbols like LE_… are not found.
Do you know if dev studio can be used with WP7702 ?
Thanks a lot for your feedback !
Best regards

François


Importing OrangeStarterKit in dev Studio
#2

Hi @francois.ravache.neo

Please can you:

  • describe shortly how you created your project in DS?
  • share a screen capture of what you’re seeing?

Thanks,
David


#3

Dear Naan,

This is my error:


I try just to follow the getting started:

  • My target is well connected
  • I create just “Hello World” app
  • Just compile and run…

Thanks for your feedback


#4

I’ve these problems:


#5

The screenshots have truncated the text.

Please copy the full text & paste here


#6

I would guess that you haven’t installed the relevant dev studio packages for the module and legato version you are trying to use. Dev studio won’t find the toolchains that are part of the command line workflow by default.


#7

Yeah, @dfrey is right.
By default DS only knows “official” product releases, that come with a bit older Legato version.

There is this topic that explains how to load an updated Legato version into DS:

@dfrey: please can you just tell where is located the up-to-date Legato framework on the filesystem in the MangOH VM?

Thanks!


#8

In the mangOH virtual machine, the Legato application framework source code is located in ~/legato_framework/legato


#9

Hi,
I tried to do that. All seems to be OK, but when I try to create a project (Hello World) or just import Orange project, I get this error:

I found a thread on Legato Forum about this issue:

We are using a standard VM for Orange challenge
So, I think that it should not be an issue from docker or DS version

I tried to restart from scratch and follow each step, but unfortunately, I get always the same error.

Please, can help me to find what I missed to do ?

Thanks for your support

Francois


#10

Hi @francois.ravache.neo

Please can you dump what are the different Target Platform instances (with configured packages) that you have in the Preference Page?


#11

In the Vm, there are no pre installed Target Platerform
I created a new plateform :
From Preference > DevStudio > TargetPlaterform> Create…
I name it ChallengeTarget
Module: WP77XX
Targetr Platefrom status : the tarhet platerform is valid
Toolchain: empty window
Application frameworl:
I selected Legato App Frmk (0.0.0778cd395-3ee7-4076-bad4-733a0fabcaac) (This one that I’ve added following your instructions)
=> Apply and close

After Project > New Project
Create Leagato App

End CRASH…


#12

Ok, I think this is the problem.
you first need to install the latest official WP77 SDK from the Packages perspective, in Available Packages view.
Then, in the Target Platform, you need to clone the Built-in one created following your install, and replace the Legato framework package with the one pointing at ~/legato_framework/legato

Then, by using this new target platform, project build should be OK.


#13

I can open project now.
Thanks for your feed back

Francois