Data connection drops randomly and radio powers down



I’m using a mangOH Red with WP7603. I’m using a third party SIM provider and not the Sierra Wireless SIM that comes with the kit. The problem we’ve been noticing recently is that the data connection drops for no apparent reason and the radio powers down. Trying to revive the radio with ‘cm radio off’, ‘cm radio on’ has no effect. The signal strength at the test location is strong, so network availability is not a likely cause. Only rebooting the device brings it back to normal. Here is the log from when it happens

Aug 23 08:01:23 swi-mdm9x28 Legato: INFO | ampmanager[3652]/ampManagerComponent T=main | udpClientServer.cpp sendData() 123 | Sent 68 bytes of data
Aug 23 08:01:42 swi-mdm9x28 user.debug Legato: DBUG | ampmanager[3652]/ampManagerComponent T=main | ampManagerComponent.cpp dataConnectionStateHandlerFunc() 94 | Data connection state event received: 0
Aug 23 08:01:42 swi-mdm9x28 user.warn Legato: -WRN- | modemDaemon[871]/le_pa T=main | pa_sim_qmi.c MapSimState() 879 | More than one application 2
Aug 23 08:01:42 swi-mdm9x28 user.warn kernel: [32055.142170] PSM: Modem oprt mode - 1
Aug 23 08:01:47 swi-mdm9x28 user.warn Legato: -WRN- | dcsDaemon[846]/le_pa_dcs T=main | pa_dcs_linux.c pa_dcs_SetDefaultGateway() 568 | Default gateway or interface is empty
Aug 23 08:01:47 swi-mdm9x28 daemon.warn dnsmasq[1352]: no servers found in /etc/resolv.conf, will retry
Aug 23 08:01:47 swi-mdm9x28 user.err Legato: =ERR= | modemDaemon[871]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 820 | Sending QMI_NAS_GET_RF_BAND_INFO_REQ_MSG_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=74.[0x4a]
Aug 23 08:01:47 swi-mdm9x28 user.err Legato: =ERR= | modemDaemon[871]/le_pa T=main | pa_mrc_qmi.c pa_mrc_GetRadioAccessTechInUse() 3328 | The device is not registered on the network
Aug 23 08:01:47 swi-mdm9x28 user.err Legato: =ERR= | modemDaemon[871]/le_pa T=main | pa_mrc_qmi.c pa_mrc_GetRadioAccessTechInUse() 3331 | Failed to retrieve the RAT

Here’s output of cm info

Device: WP7603-1
IMEI: 351711090106904
FSN: WD752585141310
Firmware Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
Bootloader Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
MCU Version: 002.009
PRI Part Number (PN): 9907595
PRI Revision: 001.004
Carrier PRI Name: GENERIC
Carrier PRI Revision: 002.032_000
SKU: 1103727
Last Reset Cause: Power Down

And legato version

root@swi-mdm9x28:~# legato version

Any clues on what could be causing this?


What SIM are you using?


We use SIM cards from Aeris.


did you set the apn correctly?
can you do cm radio status when it is connected?
Does the SIM support LTE?


Yes, as I mentioned in the opening post there is no problem with the data connection till it randomly drops and the radio powers off. Up until that point we’re receiving data from the device over an LTE network.


How are you powering these boards?


I’m using a powered 60w USB hub and the Red also has a battery hooked up. I checked the voltage reading on the on board ltc2492 when this happened and it was hovering around 4v.


does the system work well with a Sierra SIM? Please provide all information when you have such an issue. We cannot resolve issues that are SIM related.


We haven’t used Sierra SIMs at all, so unfortunately I don’t have that information. I’m just curious about why the radio powers down and doesn’t come back up until the device reboots. And specifically these messages in the log


can you run the following AT command:
AT!PCINFO? will show why the Modem radio enters LPM.


Sure, I’ll do that the next time we encounter this issue and update back here.


Hi @asyal,

We finally encountered this problem again. Here’s the output of AT!PCINFO?

State: Low Power Mode
LPM voters - Temp:0, Volt:0, User:0, W_DISABLE:1, IMSWITCH:0, BIOS:0, LWM2M:0, OMADM:0, FOTA:0
LPM persistence - None

Why would W_DISABLE be asserted and is there any way we can prevent it?



Discussing with our team, the following was recommended:

this will ignore any change to w_disable.

Can you try this and let us know?


Thanks @asyal, we’ll try it and report back.


Just to want to update here that since setting ignore w_disable we haven’t had any problems with random data connection drop outs or radio power downs. I’ll keep a close eye, but we can consider this problem solved for now. Thanks for your help!