Create mangOH Red development environment on dockers ( Native app on Windows)

Has anyone tried to install the development environment for mangOH Red on Windows native docker (without using docker-machine or Virtualbox)? I have already docker installed on Windows 10 as native app. I cannot install VirtualBox on this machine because of conflict with dockers. I want to create docker container with MangOH development environment ( including development Studio). Any help will be much appreciated.

I was intrigued by this idea, so I just tried it. I was able to install Docker Desktop on Windows 10 and I created a docker image to build a Legato system. Unfortunately, I didn’t get that far. When I ran leaf setup -p swi-wp76_4.5.1 wp76_R13.3_19.10.1, I got this:

Run sync steps for swi-verify-license_1.4.190813
You need to accept the license: sierra-v1
Press ENTER to display the license text; use "q" to quit the license viewer

Do you accept the license sierra-v1 (y/N)? y
License accepted: sierra-v1
Downloading 7 package(s)
[100%] Downloading 0f5d801-wp76-legato_19.10.1-201911271931.leaf
[100%] Downloading 93c9b86-wp76-toolchain_SWI9X07Y_02.28.03.05-linux64.leaf
[100%] Downloading 49d9075-wp76-modem-image_13.3.leaf
[100%] Downloading 14c0748-wp76-legato-image_19.10.1-201911271931.leaf
[100%] Downloading 944cdb1-wp76-linux-image_SWI9X07Y_02.28.03.05.leaf
[100%] Downloading 971bdb3-wp76-image_4.5.1.leaf
[100%] Downloading 5db42ea-swi-wp76_4.5.1.leaf
[1/7] Installing wp76-legato_19.10.1-201911271931
Run install steps for wp76-legato_19.10.1-201911271931
[2/7] Installing wp76-toolchain_SWI9X07Y_02.28.03.05-linux64
Run install steps for wp76-toolchain_SWI9X07Y_02.28.03.05-linux64
Configuring the toolchain for your environment, this may take a few minutes...
Error during installation: Error during install step for wp76-toolchain_SWI9X07Y_02.28.03.05-linux64 (command returned 1)
  Profile provisioning interrupted
  Error during install step for wp76-toolchain_SWI9X07Y_02.28.03.05-linux64 (command returned 1)
  try leaf profile sync to resume
Command exited with 2
  Sub command failed: 'leaf profile sync wp76_R13.3_19.10.1'

I’m not sure exactly what the problem is.

That is the exact point where I am stuck .