Communication with HL8548 using Uart1


#1

Hello,
I try to communicate with AirPrime HL8548 using Uart1 in slot IOT0.
The purpose is to send AT requests.
My first question: is that possible ? if yes, how.

My interface for the Uart is 1.8 volts max
I know my HL8548 works at 115200 bauds without flow control

the swtich 6 on SW401 is On position (I tested On and off position without success)
on CN600 at pin 7, my send signal is correct.

Thank you for your help
jft


#2

Hi

Yes, it is possible.
How are you trying to talk to the device? Using USB to UART?
Also, keep SW406-pin 6 in default position. By default, UART1 is available on IoT0.

regards,
Ashish


#3

Thank for you reply.
Yes, I use USB to Uart converter FTDI ref: TTL-232RG-VREG1v8-WE
The postion of SW401-pin6 is set to default (OFF)
although the “mangOH Green (DV4)user guide v1.pdf” says it has to be ON to get Uart1 directed to iot slots.

OFF seems to be the correct configuration as the Tx signal is seen on CN600-pin7 but the Rx stays steady.

best regards,
jft


#4

Hello,
I find the solution:
In “mangOH Green (DV4)user guide v1.pdf” it is written
SW401-pin8 DCDC_shutdown turn ON => Disable secondary power supplies (1V8, 3V3 and 5V0), so only the primary CF3 module is powered.

This is a big mistake

SW401-pin8 DCDC_shutdown turn ON => Also disable primary power supplies (1V8 and 3V3)

A day lost
best regards
jft


#5

Thanks. We will fix this. Is it working for you now?


#6

Did you ever get this working?? I am trying the same thing on a mangOH red with a WP8548 ( and an HL7748). I can send AT commands all day via tera term, but am wanting to send AT commands via an external MCU via UART1 on the IOT connector. (or any connector where this will work. I have tried the Raspberry Pi connector too). I have not had any success when trying to send “AT” and expecting to get an “OK” back. When I send AT!MAPUART? to the WP8548 via tera term, it returns 1,16, which means AT commands are routed via UART1 and UART2 is going to the Linux console. UART1 is routed to IOT, but I do not get any responses when I use IOT to send AT commands.

I posed this question to our vendor who suggested using Sierra Wireless chips for this project,and he forwarded it on to them and got a response …

“The default method of communication on HL/WP cell modems is a USB connection (UART commands over VCOM port). Unfortunately they need to issues commands via USB to enable AT commands on UART”.

I could understand this on the WP chip, but what is the point of this on the HL when its main communication is via UART? I am about to write back and ask more about how to be able to configure the chips via USB to get the AT commands to work via UART, but it will probably take a week to get a reply. If anyone has any information on this, would be grateful. We might have to switch chips if we cant talk to these via UART from POR.


#7

https://source.sierrawireless.com/resources/legato/howtos/customizeuart/

I think you need to set it to:
at!mapuart=1,1

I havent tried this but let me know what you get.
Also, Renfell is bringing an IoT card for UART to RS232 to the market shortly.


#8

Ok. Thanks. I will try that…I will try anything! :slight_smile:


#9

I did try this, but I think it configures like this at POR. If I run at!mapuart? I get !MAPUART:1,16. Which according to the specs means UART1 is mapped to service 1(AT) and UART2 is mapped to service 16 (which is linux console). So sending at!mapuart =1,1 makes uart1 mapped to service 1(AT). I still have a few more things to try on this ( I have just been running 2 wire UART, but I am going to try tying off RTS and CTS). I will report back. If I run my code on my MCU, I can get UART data just fine from teraterm. So my code is ok…next step will be getting these signals on a scope to see what is going on. I need to see if talking via UART1 is even feasible without configuring over USB, asap.


#10

@davidc Maybe you can contact Alex and discuss the UART-RS232 card you just designed.
The issue with running long cabled on UART is that the drive strength is not there and may cause these kind of issues.


#11

Thank you so much for your responses…very kind. We are going to get the lines on the scope tomorrow and see what is going on. If I figure this out I will share it.


#12

Are there any documents that indicate the communication settings of the UART1? For example, baud rate, parity, stop bit, etc. I assume baud rate is 115200, but I cannot find the other settings in any of the documents. I was pulled off this project, but am now back on it so I am working on the UART again via the Raspberry Pi connector (until David’s IoT board is available). I am getting responses back on UART1, but they are not as expected. I wonder if there is some mismatch in the settings. I guess I can just do trial and error but wasn’t sure if there were any documented settings.

EDIT: Turns out if I set the parity bit to NONE, then I get back meaningful information. I send AT\r on UART1 via raspberry pi connector, and I get back AT\r\r\nOK. Its progress.


#13

hi can you please tell me how can i communicate mangOH RED to Raspberry Pi UART communication.


#14