CM Data Connect fails


Hey team,
We have found that periodically our MangOH red units will not make an Air Vantage connection with cm data connect

Currently, we have one unit that hasn’t been able to successfully run a cm data connect all day, but had previously been online for approximately 4 days. Has anyone run into this before? We have tried powering the system down for several hours, reloading our system, and restarting the radio. We can confirm that we have a strong connection to our cellular provider, but can’t go any further than that.

When searching I can see that the enum for the ‘Get Connection failure 44, 12, 2, 201’ refers to a LE_MDC_DISC_PLATFORM_SPECIFIC in the Le_mdc_disconnectReason_t enum.

Screenshot of cm data connect
cm data connect

Screenshot of logs


Hi @coastalbrandon

While I can’t speak specifically about Air Vantage since our units use a custom remote comms interface, I too have experienced prolonged data connection outages.

In our case, the data connection issues tend be to related to the cell tower the modem is connecting to near our office.
We’ve experienced similar issues on different modems in the past. If we relocate the modem a few streets away the data connection suddenly works again.

Additionally, to confuse matters even more, it is sometimes caused by the access point name the modem uses - our network provider has several apn options.

Which WP module are you using? And does it support fallback to a different network type (3G, 2G)?

We’re using the WP8548 module which has 2G fallback but it’s of no use to us here in Australia so we’re entirely reliant on the 3G network.

The modules maintained a strong connection to the 3G network and were able to receive SMS messages, they just couldn’t use data. However, the 4G network was fine (confirmed on a mobile handset).

Have you tried testing the SIM card in a mobile handset?
You should be able to change the mobile network settings (apn and network mode). Try manually setting it to different networks to test the data connection on each (4G, 3G, 2G).

Another suggestion would be to test with a different cellular provider, if possible.

Hope this helps.



Just had the same “issue” and the same error code.


We used the sierra SIM that came with the mangoh and that SIM is restricted to 100MB in total! (Not per month)
Swapped the SIM with a SIM from an unopened mangoh and it worked again!

Now we just have to get sierra to give us access to these SIM cards so we can deploy our test systems with the sierra SIM…


Hey guys,

Thanks very much for the responses.

@nilsarve - oooo that is very likely. We have been pushing small photos over this SIM card now for over a month, we may have reached or limit. I’ll try another SIM right away.

@raf - thanks very much for the detailed response, we are using the WP8548 with a Sierra Wireless SIM. I am going to try moving the SIM to other MangOH units and see if the problem follows the SIM. I’m also going to load another SIM (from another provider) into this unit.


Update: Yes, it was the SIM card. I must be out of data on that particular card.