Changing RAT manually to GSM causes indefinite reboot loop


#1

Hi folks. I have a problem, I am starting legato with radio OFF, then I am executing cm radio rat GSM, everything seems to be OK, but when I am switching radio on, the module reboots immediately and only solution to make it boot is physically turning the radio off. Then module boots and I have chance to change RAT back to UMTS or AUTO, in these modes legato works perfect. There is no difference, where I am trying to change RAT manually, same scenario appears when I make it from code. Actually, there is one and only case when I can make it change, if I remove a SIM card cm radio rat GSM actually changes RAT and then I can see this change when executing cm radio, but if I insert a SIM, the module reboots again. Is there any chance to make GSM work?

Legato version: 16.07.0
Device: WP8548
Firmware: SWI9X15Y_07.11.09.00 r32989 CARMD-EV-FRMWR1 2016/08/11 18:03:20

Please help!


#2

are you using USB or dcdc power supply?


#3

I am using external power supply (5V 2A), so I am sure it is not a lack of power problem.


#4

I have tried to repeat your test on my unit but dont see the reboot.
Can you do a logread -f ? This will provide more info on your exact failure.


#5

Ok, I have executed logread -f:

root@swi-mdm9x15:~# logread -f
Oct 18 07:00:45 swi-mdm9x15 authpriv.info dropbear[1208]: Child connection from 192.168.2.3:51646
Oct 18 07:00:45 swi-mdm9x15 authpriv.notice dropbear[1208]: Auth succeeded with blank password for 'root' from 192.168.2.3:51646
Oct 18 07:00:45 swi-mdm9x15 authpriv.warn dropbear[1209]: lastlog_perform_login: Couldn't stat /var/log/lastlog: No such file or directory
Oct 18 07:00:45 swi-mdm9x15 authpriv.warn dropbear[1209]: lastlog_openseek: /var/log/lastlog is not a file or directory!
Oct 18 07:01:00 swi-mdm9x15 user.info Legato:  INFO | modemDaemon[478]/le_pa T=main | pa_mrc_qmi.c pa_mrc_GetNetworkRegState() 2040 | called

I don’t see anything related to my error.
I have attached failed initialization log, please inspect it. It always restarts after ~5 seconds after powering up.
GSM crash log (21.8 KB)

The interesting thing is when I manually pulled off the SIM card, RAT was successfully changed to GSM:

root@swi-mdm9x15:~# cm radio Power: ON Current Network Operator: RAT: GSM network (LE_MRC_RAT_GSM) Status: Not registered but currently searching for a new operator (LE_MRC_REG_SEARCHING) Signal: Very strong signal strength (5)

Can it be a SIM / cellular operator problem?


#6

Ok, I’ve found the root of the problem.

According to mangOH™ Green (DV4) Developer’s Guide I can use 4.5V to 17V power supply, so I used 5V 2A supply and connected it to DC jack, and 5V seems to be not sufficient for stable work of WP8548, I have tried to connect 12V supply and there is no sudden reboots so far.


#7

thanks for letting us know. Note, that the it is not just the power adaptor voltage rating but also the ability for the adaptor to provide a sudden increase in current as in the case for 2.
We have tested 5V adaptors with no issues.
Anyways, since everything is working it is good to know :slight_smile: