Change vid\pid or block wwan


when using the WPxx devices with Windows PC , one of the drivers loaded is the WWAN driver.

this cause an unwanted CM radio off behaviur.

also mentioned in this link : mangOH yellow Radio OFF

I would like to avoid that

option 1 : change device default VID \ PID

option 2 : remove the modem support for WWAN (I do not use it)

please advice how to accomplish that (possibly with rebuilding the kernel)

What is the current setting of at!usbcomp?

Try to disable the rmnet setting bit

I have set to disable the RMNET:

echo -e “at!usbcomp=1,1,0008000D” > /dev/ttyAT

varified this:

echo -e “at!usbcomp?” > /dev/ttyAT

Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0008000D (diag,nmea,modem,ecm) ← RMNET that existed before configuration removed

and I reset the device :

echo -e “at!reset” > /dev/ttyAT

but still when connecting to Windows PC I can see: device manager → modems → Sierra Wirless WWAN modem

please advice

How about disable the modem port in at!usbcomp setting