Cant type into terminal after ssh


After sshing into the mangOH board, I am not able to type anything on the terminal.

Tried tweking ServerAliveInterval and ClientAliveInterval, Nothing changed.

Any advice?


That’s not a problem that I have seen before. Are you using a mangOH Green or Red? Are you sshing via the ECM interface (ie IP address


I’m using MangOH green.

If I ping, the connection lasts for around 10-15 seconds and then no more ping data.

After reset, again connection lasts only for 10-15 seconds.

Same with SSH.


Are you sshing over the ECM interface (USB port) or are you using the ethernet port? Which ssh client are you using?


Sshing over USB port.

Using opensshclient on Ubuntu.

I don’t think it’s a problem with the SSH client. Sshing to any other server works perfectly.

Even pinging isn’t working so maybe not anything to do with the ssh?


It was actually working fine yesterday. I ran the hello world program also.

Today it stopped working


Try running dmesg on your Ubuntu machine and see if the USB device is disconnecting each time ssh stops working. You could also look at the output of ip addr to see if the interface shows up.


Yes the usb is disconnecting.


You could try connecting to the console port using minicom and then check the dmesg output on the target at the time that you notice the USB disconnect on the Ubuntu PC. Maybe there will be an explanation for the disconnect.