Cant ssh into mangoh red board


#1

I was trying to use the wifi from MT7697 probably did something with the standard modem interface (192.168.2.2) and I cant ssh into it anymore.

Inside board modifications:

  • wpa_supplicant.conf was modified
  • added rule to udev to add a specific driver.
  • interfaces file is modified (it just adds the wlan0/1 and its start-up scripts)

Already tried:

  • reflash the WP76xx_Release9_GENERIC_SPK.spk, no success.
  • reflashed the modem firmware from sierra wiriless (9999999_9907152_SWI9X07Y_02.16.02.00_00_GENERIC_002.032_000.spk) no success.
  • I CAN ping/ssh into other mangoh board, so probably it is not in my computer.



Is there a way to completely erase the flash and re-flash it again?


#2

Hi Leoniloris,

Any chance some IP conflict?

Instead of erase the flash, would you try erase the user partition using swiflash “-r” option?
https://source.sierrawireless.com/resources/airprime/software/swiflash/

Thx


#3

Can you log into the serial console port and run “ip addr list”? That may make the problem evident.


#4

Thank you @lotam, a single partition erase was enough.


#5

Hi @leoniloris

Good to know, would you please mark this thread as solved?

Thanks!