Can't Debug MangOH Green WP7601


So, I can now build and run programs on the WP7601. However, I can’t debug them. devMode is installed, but when I either try to attach to a running program or start and debug a running program, I get an error:

Attach to ConnectionTest
Cannot retrieve processes from adef
Cannot retrieve processes from adef

This seems similar to the issues I was having before R6. Is it? Is there a work around?



Hi @Evets

Thanks for reporting this. We’ll have a look and let you know if there is a workaround.


Hi @daav,
Any luck?



Hi @Evets

I took some time to give a try with debugging a simple app which loops on emitting a trace.
Tests were done on WP76 running R6 (Legato 17.08.1), with Developer Studio 5.3

On Windows:

  • tested attach debug while connected through USB: OK
  • tested attach debug while connected through Ethernet: OK
  • tested “from start” debug while connected on USB: Failed (GDB cannot start) – investigating on this

On Linux

  • tested attach debug while connected through Ethernet: OK
  • (unable to test on USB since it is broken on Linux with Release 6)

Note that to enable SSH over Ethernet, it was necessary to do a

iptables -F && iptables -A INPUT -j ACCEPT && iptables -A FORWARD -j ACCEPT

on the device in order to temporary set the firewall down.

Please can you elaborate on your use case?
Please can you share the app you’re trying to debug?


So, after investigation, it appears that we have this limitation on WP76 Release 6: using “debug from start” mode is not working.
That said, using the attach mode should run OK in any case.


Thanks @daav for checking.

So, in my case, I need to have access to my local network. I don’t have a second ethernet port that I can use, but I’ll see if I can pick up a USB->Ethernet at a local store. I was pretty sure I’d tried the attachment method, but I will check again.
FYI though…
Under Windows, my Developer studio is 5.2 and won’t update to 5.3. Additionally, I have problems getting certain items to resolve. For example: le_mdc_ProfileRef_t does not resolve. The same project in my Linux VM WILL resolve, but I have to bring up the studio, click on Project/C++ Index/Rebuild, then quit the app, then restart Dev Studio. If I pause and restart Linux, I have to go through the same ritual again.
I can run Linux in a VM with the docker running and connect to the device just fine without going through the Ethernet cable as long as I have docker up and not adding the device to the VM.

Also, I am unable to update Dev Studio in Windows via the update process. I get these errors:

An error occurred while collecting items to be installed
session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.github.jnr.jffi,1.2.11.v20170413-2020
No repository found containing: osgi.bundle,com.github.jnr.jffi.native,1.2.11.v20170413-2020
No repository found containing: osgi.bundle,,21.0.0.v20170206-1425
No repository found containing: osgi.bundle,,58.2.0.v20170418-1837
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,com.swi.cdt.settings,
No repository found containing: osgi.bundle,com.swi.cdt.ui,
No repository found containing: osgi.bundle,com.swi.commons.core,
No repository found containing: osgi.bundle,com.swi.commons.ui,
No repository found containing: osgi.bundle,com.swi.devenv.legato.branding,
No repository found containing: osgi.bundle,com.swi.devstudio.core,
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,com.swi.devstudio.intro,
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,com.swi.docker.core,
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,com.swi.docker.ui,
No repository found containing: osgi.bundle,com.swi.ebs.commons.branding,
No repository found containing: osgi.bundle,com.swi.ebs.commons.core,
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,com.swi.ebs.commons.ui,
No repository found containing: osgi.bundle,com.swi.ebs.legato.compat,
No repository found containing: osgi.bundle,com.swi.ebs.legato.core,
No repository found containing: osgi.bundle,com.swi.ebs.legato.docker,
No repository found containing: osgi.bundle,,
No repository found containing: osgi.bundle,com.swi.ebs.legato.ui,
No repository found containing: osgi.bundle,com.swi.ebs.legato.utils,
No repository found containing: osgi.bundle,com.swi.ebstb.commons.core,
No repository found containing: osgi.bundle,com.swi.ebstb.legato.branding,


Hi @Evets

Concerning your upgrade problem on Windows, this is a recurring one we have for some time, only on Windows, random enough to give some headache each time we’re working on resolving it.

There a workaround, explained here:

Concerning your symbols resolution problem, would it be possible to share your project? Or a minimum one that reproduces the problem?
(Please include the whole folder, including .* files, but without the output Target_XXX directory to reduce size)


Hi @daav, (10.3 KB)

Well, they finally put the 5.3 version installer for Windows out there and I just installed over what I had. I don’t seem to have the resolution problem anymore, but I’m having linking issues where I need a particular module (le_mdc) but I don’t seem to know how to get it included correctly. The message I get is:

Client interface ‘le_mrc’ of component ‘ConnectionTestComponent’ in executable ‘ConnectionTest’ is unsatisfied. It must either be declared an external (inter-app) required interface (in an “extern:” section in the .adef) or be bound to a server side interface (in the “bindings:” section of the .adef).

I modeled this after the mdcTest.c and the code is essentially only this test, as I’ve not made many code changes that should effect it in any way. In my current version, I put the bindings: section based on the build for mdctest.c but I just can’t get it to link.

I tried putting the le_mdc in the extern block, but apparently it’s expecting more. How the heck do you include these other modules the correct way? Clearly there is something I’m missing.

I’ve hopefully uploaded the project. Let me know if you need anything else.



Hi @Evets

The only issues I found in your project were:

  • your Component.cdef was requiring for le_mrc.api instead of le_mdc.api
  • there were two missing “;” in your .c file

Once fixed, I can get the project building.


Doh! How embarrassing… I even had some others looking over my shoulder. Still, the errors I got didn’t point to the correct problem(s). It just complained about the adef.